Bug 176353 - php-mysql module failing to load mysqlclient library
php-mysql module failing to load mysqlclient library
Status: CLOSED DUPLICATE of bug 176316
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 12:48 EST by Jay Lee
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-22 07:18:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Lee 2005-12-21 12:48:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
Installed Fedora Core 5 test 1, yum updated to latest rawhide of all packages.

after /etc/init.d/http start /var/log/httpd/error_log says:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/mysql.so' - libmysqlclient.so.15: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/mysqli.so' - libmysqlclient.so.15: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/pdo_mysql.so' - libmysqlclient.so.15: cannot open shared object file: No such file or directory in Unknown on line 0
[Wed Dec 21 11:47:45 2005] [notice] Apache/2.2.0 (Fedora) configured -- resuming normal operations

mysql-5.0.16-4 is installed as is mysql-devel.  libmysqlclient.so.15 is present in /usr/lib64/mysql/ directory.

Rebuilding php source rpm against installed mysql rpms does not resolve problem.

"ln -s /usr/lib64/mysql/libmysqlclient.so.15 /usr/lib64/libmysqlclient.so.15" solves the problem.

Version-Release number of selected component (if applicable):
php-mysql-5.1.1-6

How reproducible:
Always

Steps to Reproduce:
Install rawhide.

yum install php-mysql

/etc/init.d/httpd restart.

php-mysql does not load.
  

Actual Results:  php-mysql module does not load.

Expected Results:  php-mysql module should load

Additional info:

Have not had a chance to test on i386 architecture so not sure if this is a x86_64 bug or multiplatform issue.  My guess is the latter.
Comment 1 Joe Orton 2005-12-21 15:22:24 EST
What's the output of:

# rpm -V mysql
# cat /etc/ld.so.conf
# cat /etc/ld.so.conf.d/mysql-x86_64.conf
# ldconfig
# ldd /usr/lib64/php/modules/pdo_mysql.so
Comment 2 Jay Lee 2005-12-21 16:21:04 EST
(In reply to comment #1)
> What's the output of:
> # rpm -V mysql
[root@CHURCHMIN-SW php.d]# rpm -V mysql prelink: /usr/bin/mysql: at least one of
file's dependencies has changed since prelinking
S.?.....    /usr/bin/mysql
prelink: /usr/bin/mysql_config: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/mysql_config
prelink: /usr/bin/mysql_waitpid: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/mysql_waitpid
prelink: /usr/bin/mysqladmin: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/mysqladmin
prelink: /usr/bin/mysqlbinlog: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/mysqlbinlog
prelink: /usr/bin/mysqlcheck: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/mysqlcheck
prelink: /usr/bin/mysqldump: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/mysqldump
prelink: /usr/bin/mysqlimport: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/mysqlimport
prelink: /usr/bin/mysqlshow: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/mysqlshow
prelink: /usr/lib64/mysql/libmysqlclient.so.15.0.0: at least one of file's
dependencies has changed since prelinking
S.?.....    /usr/lib64/mysql/libmysqlclient.so.15.0.0

> # cat /etc/ld.so.conf

[root@CHURCHMIN-SW php.d]# cat /etc/ld.so.conf
include ld.so.conf.d/*.conf

> # cat /etc/ld.so.conf.d/mysql-x86_64.conf

[root@CHURCHMIN-SW php.d]# cat /etc/ld.so.conf.d/mysql-x86_64.conf
/usr/lib64/mysql

> # ldconfig

[root@CHURCHMIN-SW php.d]# ldconfig
bash: ldconfig: command not found
[root@CHURCHMIN-SW php.d]# /sbin/ldconfig
[root@CHURCHMIN-SW php.d]#

> # ldd /usr/lib64/php/modules/pdo_mysql.so

[root@CHURCHMIN-SW php.d]# ldd /usr/lib64/php/modules/pdo_mysql.so
        libmysqlclient.so.15 => /usr/lib64/libmysqlclient.so.15 (0x00002aaaaabc0000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00002aaaaae0e000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aaaaaf22000)
        libnsl.so.1 => /lib64/libnsl.so.1 (0x00002aaaab057000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaab16e000)
        libssl.so.6 => /lib64/libssl.so.6 (0x00002aaaab2f0000)
        libcrypto.so.6 => /lib64/libcrypto.so.6 (0x00002aaaab438000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaab678000)
        libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2 (0x00002aaaab8b0000)
        libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00002aaaab9c9000)
        libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00002aaaabb3d000)
        libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00002aaaabc3f000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00002aaaabd63000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaabe78000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
        libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00002aaaabf7c000)
Comment 3 Joe Orton 2005-12-22 07:18:11 EST
Apparently there was a problem with ldconfig; you should remove the symlink you
created and update glibc.

*** This bug has been marked as a duplicate of 176316 ***

Note You need to log in before you can comment on or make changes to this bug.