Bug 176316 - ld.so isn't looking outside of /lib and /usr/lib for libraries
ld.so isn't looking outside of /lib and /usr/lib for libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 176353 176354 (view as bug list)
Depends On:
Blocks: 176366
  Show dependency treegraph
 
Reported: 2005-12-21 05:45 EST by Brian Gerst
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.3.90-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 09:35:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Gerst 2005-12-21 05:45:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
The recent glibc update appears to have broken ld.so such that it does not look outside of the standard lib dirs.  QT is affected by this for example.  ldconfig -p shows the QT libraries, but running any QT apps fails.

Version-Release number of selected component (if applicable):
glibc-2.3.90-21  

How reproducible:
Always

Steps to Reproduce:
1. Run a QT app (such as kmines)

Actual Results:  kmines: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory


Expected Results:  App finds libraries and runs.

Additional info:
Comment 1 Brian Gerst 2005-12-21 06:00:15 EST
On FC4:
$ LD_DEBUG=libs /bin/echo
     11933:     find library=libc.so.6 [0]; searching
     11933:      search cache=/etc/ld.so.cache
     11933:       trying file=/lib/libc.so.6
     11933:
     11933:
     11933:     prelink checking: ok
     11933:
     11933:     calling init: /lib/libc.so.6
     11933:
     11933:
     11933:     initialize program: /bin/echo
     11933:
     11933:
     11933:     transferring control: /bin/echo
     11933:

     11933:
     11933:     calling fini: /bin/echo [0]
     11933:
     11933:
     11933:     calling fini: /lib/libc.so.6 [0]
     11933:


On Rawhide:
$ LD_DEBUG=libs /bin/echo
      6363:     find library=libc.so.6 [0]; searching
      6363:      search cache=/etc/ld.so.cache
      6363:      search
path=/lib64/tls/x86_64:/lib64/tls:/lib64/x86_64:/lib64:/usr/lib64/tls/x86_64:/usr/lib64/tls:/usr/lib64/x86_64:/usr/lib64
            (system search path)
      6363:       trying file=/lib64/tls/x86_64/libc.so.6
      6363:       trying file=/lib64/tls/libc.so.6
      6363:       trying file=/lib64/x86_64/libc.so.6
      6363:       trying file=/lib64/libc.so.6
      6363:
      6363:
      6363:     prelink checking: failed
      6363:
      6363:     calling init: /lib64/libc.so.6
      6363:
      6363:
      6363:     initialize program: /bin/echo
      6363:
      6363:
      6363:     transferring control: /bin/echo
      6363:

      6363:
      6363:     calling fini: /bin/echo [0]
      6363:
      6363:
      6363:     calling fini: /lib64/libc.so.6 [0]
      6363:


Note how rawhide skips the cache and uses the system search path to find the libs.
Comment 2 Jakub Jelinek 2005-12-21 09:35:42 EST
Should be fixed in glibc-2.3.90-22.
Comment 3 Jakub Jelinek 2005-12-21 13:43:12 EST
*** Bug 176354 has been marked as a duplicate of this bug. ***
Comment 4 Joe Orton 2005-12-22 07:18:18 EST
*** Bug 176353 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.