Bug 176354 - Dynamic loader appears to be ignoring ld.so.conf.d
Dynamic loader appears to be ignoring ld.so.conf.d
Status: CLOSED DUPLICATE of bug 176316
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 12:53 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 13:43:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2005-12-21 12:53:52 EST
Description of problem:
With todays rawhide, trying to build a package in mock and getting:

bash-3.00# kde-config --prefix
kde-config: error while loading shared libraries: libqt-mt.so.3: cannot open
shared object file: No such file or directory
bash-3.00# ldd /usr/bin/kde-config
        libkdecore.so.4 => /usr/lib64/libkdecore.so.4 (0x00002aaaaabc6000)
        libDCOP.so.4 => /usr/lib64/libDCOP.so.4 (0x00002aaaaaf57000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaab091000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00002aaaab196000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00002aaaab2ab000)
        libart_lgpl_2.so.2 => /usr/lib64/libart_lgpl_2.so.2 (0x00002aaaab3ae000)
        libidn.so.11 => /usr/lib64/libidn.so.11 (0x00002aaaab4c6000)
        libkdefx.so.4 => /usr/lib64/libkdefx.so.4 (0x00002aaaab5f7000)
        libqt-mt.so.3 => not found
        libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00002aaaab725000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00002aaaab84b000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00002aaaab95f000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00002aaaaba70000)
        libSM.so.6 => /usr/lib64/libSM.so.6 (0x00002aaaabc70000)
        libICE.so.6 => /usr/lib64/libICE.so.6 (0x00002aaaabd7a000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaabe96000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00002aaaabfab000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaac0b4000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaac2b1000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaaac433000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaac540000)
        /lib64/ld-linux-x86-64.so.2 (0x00002aaaaaaab000)
        libqt-mt.so.3 => not found
        libqt-mt.so.3 => not found
        libqt-mt.so.3 => not found
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00002aaaac77a000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00002aaaac87c000)
bash-3.00# cat /etc/ld.so.conf.d/qt-x86_64.conf
/usr/lib64/qt-3.3/lib

ldconfig appears to update the cache properly though:

bash-3.00# strings /etc/ld.so.cache | grep qt
/usr/lib64/qt-3.3/lib/libqui.so.1
/usr/lib64/qt-3.3/lib/libqui.so
libqtmcop.so.1
/usr/lib64/libqtmcop.so.1
libqtmcop.so
/usr/lib64/libqtmcop.so
libqt-mt.so.3
/usr/lib64/qt-3.3/lib/libqt-mt.so.3
libqt-mt.so
/usr/lib64/qt-3.3/lib/libqt-mt.so

Explicitly setting the path works:

bash-3.00# export LD_LIBRARY_PATH=/usr/lib64/qt-3.3/lib
bash-3.00# kde-config --prefix
/usr

Version-Release number of selected component (if applicable):
glibc-2.3.90-21
Comment 1 Jakub Jelinek 2005-12-21 13:43:04 EST

*** This bug has been marked as a duplicate of 176316 ***

Note You need to log in before you can comment on or make changes to this bug.