Bug 176366 - karm can't find libqui.so.1(64)
karm can't find libqui.so.1(64)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On: 176316
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 14:54 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-22 14:15:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-12-21 14:54:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
Starting karm on today's rawhide/x86_64 fails with this error message:

karm: error while loading shared libraries: libqui.so.1: cannot open shared object file: No such file or directory

Re-running ldconfig, just to make sure /usr/lib64/qt-3.3/lib is searched, makes no difference.  Setting LD_LIBRARY_PATH=/usr/lib64/qt-3.3/lib works around it, but that's still ugly.

Oddly, on rawhide/i386, it works just fine.

/etc/ld.so.conf and /etc/ld.so.conf.d/qt-x86_64.conf look correct.

Version-Release number of selected component (if applicable):
kdepim-3.5.0-0.1.rc2.1 qt-3.3.5-10.1 glibc-2.3.90-21

How reproducible:
Always

Steps to Reproduce:
1.Start karm on today's rawhide

Actual Results:  karm: error while loading shared libraries: libqui.so.1: cannot open shared object file: No such file or directory


Expected Results:  It should start, since the library is there

Additional info:

Oddly, neither kdepim nor qt have changed in the past few days.  glibc, OTOH, did, so this might turn out to be a new bug in glibc's loader.
Comment 1 Alexandre Oliva 2005-12-22 14:15:52 EST
This got fixed in today's rawhide, that brought in a new glibc, further
supporting the theory that the bug was there.

Note You need to log in before you can comment on or make changes to this bug.