Bug 176380 - preedit buffer emptied after mouse click
preedit buffer emptied after mouse click
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim-tables (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Qian Shen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2005-12-21 19:04 EST by Lawrence Lim
Modified: 2015-10-25 21:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 02:42:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-12-21 19:04:08 EST
Description of problem:
Through the community survey report, we have confirmed that in korean IME, the
preedit buffer gets emptied after a single mouse click. Cross checked with
Anthy, this bug does not exist.

Version-Release number of selected component (if applicable):
scim-hangul-0.2.1-2.fc5.1

How reproducible:
Always

Steps to Reproduce:
1.start gedit
2.start korean scim IME (ctrl-space)
3.enter 'Qkf'
4.mouse click anywhere in gedit

Actual results:
preedit buffer emptied

Expected results:
preedit buffer should not empty

Additional info:
Comment 1 Lawrence Lim 2005-12-21 19:14:42 EST
Some additional information: this bugs does not exist in OOo.
Comment 2 Lawrence Lim 2005-12-21 20:14:34 EST
Problem does not reside in scim-hangul. Rather, it is a problem in
scim-tables-korean.
Comment 3 Jens Petersen 2005-12-28 02:10:35 EST
scim-tables-korean has been removed from Fedora Core and Extras fwiw.

But does this affect other scim-tables tables too?
Comment 4 Jens Petersen 2006-03-27 22:44:33 EST
Hmm, I can reproduce with scim-tables-chinese too but only seems to happen
the first time the mouse is clicked for a table.
Comment 5 Qian Shen 2006-07-28 04:36:51 EDT
I've contacted James.Su with this problem. He said this because reset () will be
called by application when clicking mouse the first time. it's must be a bug of
gtk2.
Comment 6 Jens Petersen 2006-08-01 02:14:34 EDT
I just tried with scim-anthy and scim-pinyin and they also reset preedit
on a mouse click event.  scim-chewing doesn't but they may be another issue?

Note You need to log in before you can comment on or make changes to this bug.