Bug 176383 - using scim-tables-chinese caused gedit to hang
using scim-tables-chinese caused gedit to hang
Product: Fedora
Classification: Fedora
Component: scim-tables (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
Reported: 2005-12-21 19:30 EST by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-27 22:40:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-12-21 19:30:14 EST
Description of problem:
Whenever scim-tables-chinese was selected, CangJie5, Cantonese PinYin, enter any
character in gedit will cause the application to hang.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.start gedit
2.choose TC IME (Cantonese Pinyin or Cangjie 5)
3.enter 'a'
Actual results:
*** glibc detected *** /usr/bin/gedit: free(): invalid pointer: 0x0890b740 ***

Expected results:
No problem encountered

Additional info:
*** glibc detected *** /usr/bin/gedit: free(): invalid pointer: 0x0890b740 ***

(gdb) bt
#0  0x00665402 in __kernel_vsyscall ()
#1  0x00be811e in __lll_mutex_lock_wait () from /lib/libc.so.6
#2  0x00b78acc in _L_mutex_lock_4184 () from /lib/libc.so.6
#3  0x069b1740 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0x00b73474 in _int_free () from /lib/libc.so.6
#5  0x0028f74b in _dl_map_object_deps () from /lib/ld-linux.so.2
#6  0x00293cc3 in dl_open_worker () from /lib/ld-linux.so.2
#7  0x0029067e in _dl_catch_error () from /lib/ld-linux.so.2
#8  0x002943e4 in _dl_open () from /lib/ld-linux.so.2
#9  0x00c0df26 in do_dlopen () from /lib/libc.so.6
#10 0x0029067e in _dl_catch_error () from /lib/ld-linux.so.2
#11 0x00c0e09d in __libc_dlopen_mode () from /lib/libc.so.6
#12 0x00bee189 in init () from /lib/libc.so.6
#13 0x001789eb in pthread_once () from /lib/libpthread.so.0
#14 0x00bee2f0 in backtrace () from /lib/libc.so.6
#15 0x00b6d953 in __libc_message () from /lib/libc.so.6
#16 0x00b738e0 in _int_free () from /lib/libc.so.6
#17 0x00b73fa2 in free () from /lib/libc.so.6
#18 0x06a64491 in operator delete () from /usr/lib/libstdc++.so.6
#19 0x00f4aac3 in ?? ()
    at /usr/lib/gcc/i386-redhat-linux/4.1.0/../../../../include/c++/4.1.0/bits/s
tl_construct.h:121 from /usr/lib/libscim-1.0.so.8
#20 0x00f48f37 in ?? ()
---Type <return> to continue, or q <return> to quit---
    at /usr/lib/gcc/i386-redhat-linux/4.1.0/../../../../include/c++/4.1.0/bits/s
tl_construct.h:121 from /usr/lib/libscim-1.0.so.8
#21 0x0064de43 in scim::SocketInstance::do_transaction (this=0x88bf9d0,
    trans=@0xbfb0b6fc, ret=@0xbfb0b6c8) at scim_socket_imengine.cpp:925
#22 0x006504f7 in scim::SocketInstance::commit_transaction (this=0x88bf9d0,
    trans=@0xbfb0b6fc) at scim_socket_imengine.cpp:829
#23 0x0065142d in scim::SocketInstance::process_key_event (this=0x88bf9d0,
    key=@0xbfb0b73c) at scim_socket_imengine.cpp:643
#24 0x004f8184 in gtk_scim_key_snooper (grab_widget=0x8615470,
    event=0x85f0d78, data=0x0) at gtkimcontextscim.cpp:948
#25 0x06c349b4 in IA__gtk_main_do_event (event=0x85f0d78) at gtkmain.c:1687
#26 0x06e5d203 in gdk_event_dispatch (source=0x85f37b8, callback=0,
    user_data=0x0) at gdkevents-x11.c:2291
#27 0x06949943 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x0694c893 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#29 0x0694cc3c in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#30 0x06c34d3c in IA__gtk_main () at gtkmain.c:991
#31 0x08065cb8 in main ()
Comment 1 Lawrence Lim 2005-12-21 20:12:36 EST
Same error pops up when I tried to convert hangul charcaters to hanja (TC) with
Comment 2 Lawrence Lim 2005-12-22 02:25:36 EST
This affect other IMEs from functioning properly, hence, increasing the severity.
Comment 3 James Su 2006-01-10 23:17:24 EST
I can't reproduce this issue.
Comment 4 Jens Petersen 2006-03-27 22:40:10 EST
I can't reproduce this either (FC5).  A rawhide blip?

Note You need to log in before you can comment on or make changes to this bug.