Bug 176400 - each entry in the time slot should be treated as individual IC
each entry in the time slot should be treated as individual IC
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: i18n
Depends On:
Blocks: SCIM 209566
  Show dependency treegraph
 
Reported: 2005-12-22 00:04 EST by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: evolution-2.11.90-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 03:01:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evolution calendar with scim (90.28 KB, image/png)
2005-12-22 00:04 EST, Lawrence Lim
no flags Details
patch for the problem. (1.04 KB, patch)
2006-11-06 06:13 EST, Mayank Jain
no flags Details | Diff
Latest patch (4.93 KB, patch)
2006-12-20 05:42 EST, Mayank Jain
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 371705 None None None Never

  None (edit)
Description Lawrence Lim 2005-12-22 00:04:15 EST
Description of problem:
Tested evolution calendar with scim and noticed that the pre-edit buffer is not
reset when scim is activated in another time slot (input context). As a result,
previous entries gets replicated.

Version-Release number of selected component (if applicable):
evolution-data-server-1.5.2-1.1

How reproducible:
Always

Steps to Reproduce:
1.start evolution -> calendar
2.in day view, click on 1PM
3.enter a to get focus
4.ctrl-space to activate scim
5.enter 'aka'
6.click on the next time slot and enter a
7.ctrl space to activate scim and enter genki
  
Actual results:
あかげんき

Expected results:
げんき

Additional info:
Comment 1 Lawrence Lim 2005-12-22 00:04:16 EST
Created attachment 122514 [details]
evolution calendar with scim
Comment 2 Lawrence Lim 2005-12-22 00:17:24 EST
I will try the upstream version and submit a bug upstream if necessary.
Comment 3 Lawrence Lim 2006-09-25 01:08:45 EDT
evolution-2.8.0-5.fc6
Bug still exist in FC6T3. Tested with the following components:
=========================
evolution-data-server-1.8.0-9.fc6
evolution-sharp-0.11.1-8
beagle-evolution-0.2.9-1.fc6
evolution-webcal-2.7.1-6
evolution-data-server-devel-1.8.0-9.fc6


scim-1.4.4-34.fc6
scim-tables-0.5.6-7
scim-chewing-0.3.1-4.fc6
scim-bridge-gtk-0.4.5-2.fc6
scim-qtimm-0.9.4-5
scim-bridge-0.4.5-1.fc6
scim-pinyin-0.5.91-12.fc6
scim-sinhala-0.2.0-1.fc6
scim-tables-chinese-0.5.6-7
scim-m17n-0.2.0-6.fc6
scim-libs-1.4.4-34.fc6
scim-hangul-0.2.2-7.fc6
Comment 4 Mayank Jain 2006-11-06 06:13:31 EST
Created attachment 140446 [details]
patch for the problem.
Comment 5 Mayank Jain 2006-11-06 06:22:49 EST
Oops, sorry Matthew for moving to modified...
Comment 6 Matthew Barnes 2006-11-06 11:23:41 EST
Patch applied to evolution-2.9.1-3.fc7.
Comment 7 Mayank Jain 2006-11-07 00:32:25 EST
Thanks :)
Comment 8 Mayank Jain 2006-12-20 05:42:37 EST
Created attachment 144088 [details]
Latest patch
Comment 9 Mayank Jain 2006-12-26 08:17:01 EST
Based on Comment 8, moving to assigned again. Matthew, can you please update the
patch for this bug when discussion in Bug 209566 ends.

Thanks,
Mayank
Comment 11 Mayank Jain 2007-02-23 04:58:40 EST
Patch in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=209566#c38 has a
working patch for this problem.

Matthew, can you please set this bug to MODIFIED if this patch is already in
Rawhide?

Thanks.
Comment 12 Matthew Barnes 2007-08-24 16:05:30 EDT
Lawrence, can you still reproduce this bug on Fedora 7 or Rawhide?

I can't reproduce the problem with Evolution 2.11.90, but I'm not sure what the
correct behavior is supposed to be.
Comment 13 A S Alam 2007-08-27 03:01:45 EDT
yes, I m not able to reproduce problem with following version:
evolution-2.11.90-4.fc8

Note You need to log in before you can comment on or make changes to this bug.