Bug 1764408 - [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-default token max age to generate tokens that do not expire works as expected when using a code authorization flow [Suite:openshift/conformance/parallel]
Summary: [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-defa...
Keywords:
Status: CLOSED DUPLICATE of bug 1765733
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Stefan Schimanski
QA Contact: scheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-23 02:55 UTC by huirwang
Modified: 2019-11-06 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 13:21:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description huirwang 2019-10-23 02:55:12 UTC
Descriptions of problems:
[Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-default token max age to generate tokens that do not expire works as expected when using a code authorization flow [Suite:openshift/conformance/parallel] expand_less 	44s
fail [github.com/openshift/origin/test/extended/oauth/expiration.go:169]: Unexpected error:
    <*errors.StatusError | 0xc0029c2a00>: {
        ErrStatus: {
            TypeMeta: {Kind: "", APIVersion: ""},
            ListMeta: {
                SelfLink: "",
                ResourceVersion: "",
                Continue: "",
                RemainingItemCount: nil,
            },
            Status: "Failure",
            Message: "Unauthorized",
            Reason: "Unauthorized",
            Details: nil,
            Code: 401,
        },
    }
    Unauthorized
occurred


https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-e2e-gcp-4.3/398

related jobs:
https://testgrid.k8s.io/redhat-openshift-release-4.3-informing-ci#release-openshift-origin-installer-e2e-gcp-4.3&show-stale-tests=

Comment 1 Michal Fojtik 2019-11-06 13:21:09 UTC

*** This bug has been marked as a duplicate of bug 1765733 ***


Note You need to log in before you can comment on or make changes to this bug.