Bug 1765733 - [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-default token max age to generate tokens that do not expire works as expected when using a code authorization flow
Summary: [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-defa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Standa Laznicka
QA Contact: scheng
URL:
Whiteboard:
: 1764408 1765734 (view as bug list)
Depends On:
Blocks: 1791855
TreeView+ depends on / blocked
 
Reported: 2019-10-25 20:11 UTC by Anurag saxena
Modified: 2020-03-23 10:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:09:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24239 'None' closed [release-4.3] Bug 1765733: extended util oauthserver - increase pod ready wait time 2020-05-13 16:22:04 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:09:58 UTC

Description Anurag saxena 2019-10-25 20:11:06 UTC
Description of problem:
fail [github.com/openshift/origin/test/extended/oauth/expiration.go:30]: Unexpected error:
    <*errors.errorString | 0xc00027c100>: {
        s: "timed out waiting for the condition",
    }
    timed out waiting for the condition
occurred

Additional info:
https://testgrid.k8s.io/redhat-openshift-release-4.3-informing-ocp#release-openshift-ocp-installer-e2e-azure-4.3
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-azure-4.3/244

Comment 1 Michal Fojtik 2019-11-06 13:21:09 UTC
*** Bug 1764408 has been marked as a duplicate of this bug. ***

Comment 2 Michal Fojtik 2019-11-06 13:21:14 UTC
*** Bug 1765734 has been marked as a duplicate of this bug. ***

Comment 4 Neelesh Agrawal 2019-11-27 19:44:14 UTC
Still see these failures ~15% of the times:
https://testgrid.k8s.io/redhat-openshift-ocp-release-4.4-informing#release-openshift-ocp-installer-e2e-azure-4.4
Can this be fixed in 4.3 timeframe?

Comment 5 Standa Laznicka 2019-11-28 07:54:40 UTC
There's a patch already for master, just waiting for it to merge so that we can backport it to 4.3 - https://github.com/openshift/origin/pull/24217

Comment 10 errata-xmlrpc 2020-01-23 11:09:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.