Bug 17650 - Netscape fonts ugly/misrendered if AbiWord installed
Summary: Netscape fonts ugly/misrendered if AbiWord installed
Status: CLOSED DUPLICATE of bug 18855
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: abiword   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-18 18:34 UTC by Chris Evans
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 05:08:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Evans 2000-09-18 18:34:19 UTC
Hi,

If AbiWord is installed, then netscape's fonts seem to be affected. This is
a regression versus
RedHat6.2, and very ugly.

A site which demonstrates this well is "linuxtoday.com". The font used for
the story summaries is gross; the letters flow into each other are are
slightly blocky. This can be seen very clearly using the "xmag" tool.

If you edit /etc/X11/fs/config and remove the AbiWord line, then kill -HUP
`pidof xfs`, and restart netscape, the fonts are back to RH6.2 standards.

Some extra useful comments from mattdm@mattdm.org, which note that this may
not
technically be a Netscape problem. However, after deliberation I've filed
it against
Netscape, because the user-visible effects of this bug manifest themselves
in Netscape.
--
No, I don't think so. I was still contemplating if it's an AbiWord problem,
a Netscape problem, or a Red Hat one.

It doesn't mess up Mozilla, because Mozilla uses full font names including
foundry. And it seems like AbiWord would be better served by making
differently named fonts which it knows are substitutable for Times New
Roman
et al if necessary, rather than claiming they're something they're not.
--

Comment 1 Chris Evans 2000-09-18 18:37:58 UTC
Some more useful info from mattdm@mattdm.org
--
Did you install AbiWord? 

I had this problem too. AbiWord installs some REAALLLLY ugly fonts that it
claims are Times New Roman, Arial, and Courier New. I use the genuine
Monotype fonts by those names (left over from the Windows95 installation
that used to be on this machine) and have Netscape configured to look for
them. However, the AbiWord fonts get in the way and make everything look
nasty. Solution: remove the AbiWord entry from /etc/X11/fs/config.
--

Comment 2 Bill Nottingham 2000-09-18 18:42:39 UTC
Assigning to abiword; that's where any fix will have to be
(changing the names of the fonts, for example.)

Comment 3 Bernhard Rosenkraenzer 2000-10-12 15:13:33 UTC

*** This bug has been marked as a duplicate of 18855 ***


Note You need to log in before you can comment on or make changes to this bug.