Bug 18855 - Abiword installed causes very ugly system fonts
Abiword installed causes very ugly system fonts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: abiword (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
: 17650 31094 58476 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 17:44 EDT by Tim Mann
Modified: 2007-03-26 23:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 01:59:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Poor font rendering with Konqueror when abiword installed (163.85 KB, image/jpeg)
2001-04-08 20:08 EDT, Chris Evans
no flags Details
fonts.scale for AbiWord fonts that uses actual font names (5.40 KB, text/plain)
2002-01-28 23:10 EST, rdt
no flags Details

  None (edit)
Description Tim Mann 2000-10-10 17:44:28 EDT
AbiWord installs some fonts with fictitious family names, as a kludge for
people who don't have the real fonts with those names.  For instance,
Nimbus Sans is installed under the family name Arial.  Unfortunately, if
you have the real Monotype Arial truetype font installed (having downloaded
it as part of the free font pack available from Microsoft), programs that
simply ask for Arial without specifying the foundry will get the inferior
Nimbus Sans font instead of the real Arial.  I guess this happens because
the "abisource" foundry comes before "monotype" in alphabetical order.

A sample program that is affected is Netscape when displaying
www.slashdot.org. This web page asks for the face "arial" for article
titles.  Without the AbiWord package installed, it was getting the real
Arial and looked nice. After I upgraded to RH 7 and decided to install
AbiWord to give it a try, suddenly I was getting an ugly font on that page.

The best fix for this might be for AbiWord to have a built-in font
substitution table, so that when an imported Word document asks for Arial
and the user doesn't have it installed, AbiWord maps the name to some other
sans-serif font.  I actually think that this table should initially be
empty, and the user should get a pop-up dialog box whenever an uninstalled
font is found in a document, giving the option to add a substitution either
permanently or just for this document or session, and suggesting that the
user get the real font as a long-term solution. Obviously that would have
to be considered and implemented by the AbiWord team.  I don't have a good
shorter-term fix to suggest for the Red Hat package.

It might be a good idea for AbiWord to not install any fonts at all, but
instead (at least in the Red Hat packaging) to explicitly depend on the
XFree86 packages that have the fonts it needs. It looks like most of the
fonts in the AbiWord package are actually standard X fonts installed under
different foundry and/or family names. That seems to just add confusion and
pollution to the font name space, which is bad enough already. However, if
some of the fonts are new (Dingbats and Standard Symbols?) or have been
usefully improved (adding missing characters?) then I can see more
justification for shipping fonts with AbiWord.
Comment 1 Bernhard Rosenkraenzer 2000-10-12 11:02:09 EDT
Red Hat Linux does not ship some of the fonts AbiWord depends on (Arial, Times New Roman) in any other package, so they have to be included with AbiWord.
I'm forwarding the request for a font translation table to the AbiWord developers; I don't think we should just throw a huge change like this one in without their consent.
Comment 2 Bernhard Rosenkraenzer 2000-10-12 11:06:40 EDT
Since the fonts are not in the standard font directories, the obvious workaround is to add the font path only when AbiWord is started (i.e. modify the AbiWord startup script) and removing it when AbiWord exits.
Unfortunately, that prevents people who don't have other fonts by the same names from using them elsewhere...
Comment 3 Bernhard Rosenkraenzer 2000-10-12 11:10:31 EDT
Submitted as Bug 1030 in abiword's bugzilla.
Comment 4 Bernhard Rosenkraenzer 2000-10-12 11:13:22 EDT
*** Bug 17650 has been marked as a duplicate of this bug. ***
Comment 5 Tim Mann 2000-10-12 13:58:52 EDT
I agree that this needs to be fixed by the AbiWord folks, not by RedHat, though
it is a pitfall other RedHat users could hit, so it would be nice to have a
simple workaround. Unfortunately I haven't found one other than "rpm -e
abiword". I did find out a little more about the problem.

- AbiWord uses only the fonts it installed. It seems to need to know what
directory they are in, but I'm not certain of that.

- AbiWord prints an error message and quits if it can't find a font called
-AbiSource-Times New Roman-...

- If you alias -AbiSource-{Arial,Times New Roman,Courier New}-... to the
corresponding real TrueType fonts (-Monotype-...), AbiWord hangs during startup,
so this is not a workaround.  I don't know the cause of the hang; could be that
it needs to find the fonts in a known directory and thus can't handle aliases,
could be that it can't  handle TrueType, could be that it needs *exactly* the
fonts that come with it in order to work. Oh well, I'm guessing here.

- AbiWord's startup script adds its font directory to the path.  This is
actually not a great idea, since other applications started while AbiWord is
running will see the added fonts.  What's worse, the script does not check
whether the font directory is already on the font path, and the directory is not
removed from the path when AbiWord exits.  So it ends up getting on the path
repeatedly.
Comment 6 Chris Evans 2001-02-06 12:25:41 EST
(Summary changed)
This still affects BETA3, the public beta.
I did the install and for whatever reason Abiword got installed.
Upon firing up Netscape I was faced with very ugly and slightly
blocky fonts. Some of the glyphs touch.

This is a very visible bug and is going to turn people off
Linux substantially.
Comment 7 Chris Evans 2001-04-08 20:05:45 EDT
Affects Konqueror too!
Attaching screenshot zooming in on fonts with
and without abiword installed. This is viewing
the linuxtoday.com site.
In the bad fonts case notice the lack of symmetry
of many fonts. Also, some fonts "touch", and some
of the glpyhs are whacky (e.g. "r", "3")

Comment 8 Chris Evans 2001-04-08 20:08:03 EDT
Created attachment 14965 [details]
Poor font rendering with Konqueror when abiword installed
Comment 9 Chris Evans 2001-04-08 20:18:48 EDT
See also: bug #31094.
Abiword is not the only source of poor fonts
which uglify your desktop.

Comment 10 Akkana 2001-04-08 20:57:00 EDT
What are some of the other packages?  I don't have abiword installed (RH7) but I
still have ugly incorrectly scaled Arial fonts.  I tried to look at bug 31094,
but bugzilla tells me I don't have permission.
Comment 11 Chris Evans 2001-04-09 18:24:14 EDT
Bug 31094 complains about XFree86-ISO8859-7-Type1-fonts.
There may be other culprits. I usually blow away all fonts possible,
leaving the standard 75dpi and 100dpi X fonts. This also has the
side effect of making netscape launch over twice as fast.
Comment 12 Matthew Miller 2001-04-27 19:31:07 EDT
Abiword is now accepting votes for which bugs should be fixed for their 0.9 and
1.0 releases. I suggest that people who want this fixed go add their votes at 
http://bugzilla.abisource.com/show_bug.cgi?id=1030
Comment 13 Chris Evans 2001-08-06 17:39:17 EDT
STILL an issue with RH7.2beta3
i.e.
"OH MY GOD they broke the fonts"
"Oh no, actually I just forgot to rpm -e abiword"
Comment 14 Bernhard Rosenkraenzer 2001-08-29 07:02:13 EDT
*** Bug 31094 has been marked as a duplicate of this bug. ***
Comment 15 Need Real Name 2001-11-13 15:47:17 EST
Just couple of comments; AbiWord does not have to use the fonts that come with 
it, it can handle both Type1 and TrueType (ttf), and the user can reconfigure 
the AW font directory to his/her liking; AW <=0.9.4 does require Times New 
Roman, but that restriction will be lifed at 0.9.5. I works very nice with the 
MS fonts.

The problem which is peculiar to RH, is that on RH the configuration is such 
that xset +fp cannot be used to add the AW font path (because the X server 
Type1 module is by default not loaded). This means that the user has to add the 
AW font directory permanently to the xfs configuration. This does not happen on 
other distros, where the path is only modified whil AW is running.
Comment 16 Tim Mann 2001-11-14 01:26:41 EST
Two responses to the last comment.

1) When I first filed this bug, AbiWord would crash if I tried to use real
Monotype Times Roman and Arial with it.  If that is fixed now, that's
good to hear.

2) Adding something bogus to the font path while AbiWord is running and removing
it afterwards is a totally wrong approach.  AbiWord should not assume that it is
taking over the computer while it is running.  If it puts something bogus on the
font path while it is running, like an ugly font named "Arial" that is not
really Arial, any application started while AbiWord is running will
see the bogus font and may select it by mistake.
Comment 17 Bryce Nesbitt 2002-01-11 15:36:35 EST
As of RedHat Linux 7.2, this is still a problem.  "rpm -e abiword" is the
easiest solution.
AbiSource is still taking votes on this issue at:
	http://bugzilla.abisource.com/show_bug.cgi?id=1030
But there are no plans to fix it.
Comment 18 Bryce Nesbitt 2002-01-15 17:51:59 EST
A hacky patch has been applied for AbiWord 1.0.  The fonts will now be installed
with a foundary of "zz_abiword", which places them last.  The Abi fonts will
show up only if no other font of the requested family is installed. 
Better'Nothing.
Comment 19 Matthew Miller 2002-01-15 18:35:30 EST
They oughta call the fonts "abiarial", "abitimes", etc., and map them internally
if no real arial, etc. are found. At least, that's what I think. :)
Comment 20 Bryce Nesbitt 2002-01-15 20:48:48 EST
The Arial font AbiWord installs in the system font path is still actually
Nimbus.  The Courier is actually Nimbus Mono .  Unless correct fonts are
available earlier in the font path, there will still be a problem.

Simply distributing a crappy font is not a crime. Lying about a font's family
is, to me, unforgivable
Comment 21 Bernhard Rosenkraenzer 2002-01-18 13:29:05 EST
*** Bug 58476 has been marked as a duplicate of this bug. ***
Comment 22 rdt 2002-01-28 23:05:41 EST
AbiWord does something unforgivable: they designate knock-off fonts from URW
by trademarked names such as Arial and Times New Roman.  And many users are
complaining about it because "Abi" as a foundry precedes Monotype or Adobe.
But the urw-fonts package distributed by RedHat does the same kind of thing! 
For example, URW's Palladio is designated Palatino.  The only reason that this
hasn't caused as many problems is that URW comes after everything else,
alphabetically, and real Palatino et al are not downloadable for free.  I think
RedHat and Abi should both stop this mislabelling of fonts.  Applications can
substitute fonts but should not mislabel them.
Comment 23 rdt 2002-01-28 23:10:34 EST
Created attachment 43856 [details]
fonts.scale for AbiWord fonts that uses actual font names
Comment 24 sdh4 2002-06-13 22:27:36 EDT
This bug still exists. An out-of-box installation of RH7.3 (Laptop, Gnome, no
KDE,  devel, games) gives Mozilla and Galeon horrible blocky unreadable Arial
fonts. 

At minimum, there should be an alias directory for Arial put into the font path, 
as described at http://patriot.net/~scoile/fonts/fixing-3.html

It is absolutely unconsionable that this bug still exists in an out-of-box
installation, well over a year after it was first reported.
Comment 25 Jeremy Katz 2002-07-18 00:32:01 EDT
Post-1.0 versions of abiword re-namespace their fonts to the zzAbiword foundry
which helps, and 1.0.2-1 and later don't put in aliases for these common fonts
anymore.

Note You need to log in before you can comment on or make changes to this bug.