Bug 1765177 - Many router e2e tests are flaky due to a buggy wait script
Summary: Many router e2e tests are flaky due to a buggy wait script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.0
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks: 1765179 1765181
TreeView+ depends on / blocked
 
Reported: 2019-10-24 13:17 UTC by Dan Mace
Modified: 2020-01-23 11:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1765179 1765181 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:09:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24012 0 'None' closed Bug 1765177: e2e: fix flaky route wait function 2020-02-12 22:41:41 UTC
Github openshift origin pull 24028 0 'None' closed e2e: fix more flaky route wait functions 2020-02-12 22:41:41 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:09:35 UTC

Description Dan Mace 2019-10-24 13:17:50 UTC
Description of problem:

Many router tests use waitForRouterOKResponseExec() to wait for test route
connectivity. However, due to a bug in the check script, if the underlying
curl command times out once during checks, the waitForRouterOKResponseExec()
function will always time out even if the target route becomes responsive.

If the curl command itself never times out, the function works properly.

Other bugs which are likely explained by this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1753472
https://bugzilla.redhat.com/show_bug.cgi?id=1753734
https://bugzilla.redhat.com/show_bug.cgi?id=1762653
https://bugzilla.redhat.com/show_bug.cgi?id=1762149
https://bugzilla.redhat.com/show_bug.cgi?id=1764076
https://bugzilla.redhat.com/show_bug.cgi?id=1764079
https://bugzilla.redhat.com/show_bug.cgi?id=1764081


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dan Mace 2019-10-25 11:28:43 UTC
Also depends on https://github.com/openshift/origin/pull/24028

Comment 3 Hongan Li 2019-10-30 05:36:01 UTC
monitoring the e2e test for some days to ensure the fix works.

Comment 5 Hongan Li 2019-11-04 02:00:18 UTC
the related bugs have been verified so moving this to verified too.

Comment 7 errata-xmlrpc 2020-01-23 11:09:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.