Bug 1765179 - [4.2] Many router e2e tests are flaky due to a buggy wait script
Summary: [4.2] Many router e2e tests are flaky due to a buggy wait script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.z
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On: 1765177
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-24 13:19 UTC by Dan Mace
Modified: 2019-11-19 13:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1765177
Environment:
Last Closed: 2019-11-19 13:49:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24063 'None' 'closed' '[release-4.2] Bug 1765179: e2e: fix flaky route wait functions' 2019-11-15 19:34:16 UTC
Red Hat Product Errata RHBA-2019:3869 None None None 2019-11-19 13:49:12 UTC

Description Dan Mace 2019-10-24 13:19:32 UTC
+++ This bug was initially created as a clone of Bug #1765177 +++

Description of problem:

Many router tests use waitForRouterOKResponseExec() to wait for test route
connectivity. However, due to a bug in the check script, if the underlying
curl command times out once during checks, the waitForRouterOKResponseExec()
function will always time out even if the target route becomes responsive.

If the curl command itself never times out, the function works properly.

Other bugs which are likely explained by this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1753472
https://bugzilla.redhat.com/show_bug.cgi?id=1753734
https://bugzilla.redhat.com/show_bug.cgi?id=1762653
https://bugzilla.redhat.com/show_bug.cgi?id=1762149
https://bugzilla.redhat.com/show_bug.cgi?id=1764076
https://bugzilla.redhat.com/show_bug.cgi?id=1764079
https://bugzilla.redhat.com/show_bug.cgi?id=1764081


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Hongan Li 2019-11-12 06:55:06 UTC
didn't see the issue in recent 4.2 CI job. moving to verified.

Comment 4 errata-xmlrpc 2019-11-19 13:49:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3869


Note You need to log in before you can comment on or make changes to this bug.