Bug 176518 - Error writing to disc
Error writing to disc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
: 177968 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-12-23 20:16 EST by John Ellson
Modified: 2013-01-09 22:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 05:47:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-12-23 20:16:57 EST
Description of problem:
*** I consider this bug a blocker for FC5T2 ***

Every time I try to write an iso to CD/R using nautilus I get "Error writing to
disc" popup.

This may be the same as bz# 163799, which was linked upstream to 
http://bugzilla.gnome.org/show_bug.cgi?id=324252
but upstream claims that it was fix in 2.12 and this is with 2.13.3
so perhaps the bug has come back, or perhaps it is a different bug.

Version-Release number of selected component (if applicable):
nautilus-cd-burner-2.13.3-1


How reproducible:
100%

Steps to Reproduce:
1. select "write to disc" on a .iso image
2. get "write to disc" popup, click on "write"
3. cd drawer closes with writable disc, get "insert a writable disk popup",
click on :OK:
  
Actual results:
"Error writing to disc" popup.  Disc ejected.

/var/log/messages contains:
    Dec 23 20:07:37 ontap kernel: cdrom: This disc doesn't have any tracks I
recognize!

which is odd because it sounds like it is trying to read the disc which hasn't
been written yet.




Expected results:


Additional info:
Comment 1 Harald Hoyer 2006-01-18 05:47:08 EST
Should work now with recent cdrecord/cdrdao rpms
Comment 2 Bastien Nocera 2006-01-19 06:40:24 EST
*** Bug 177968 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2006-01-19 06:42:31 EST
Harald, in which version would this have been fixed?

From the dupe, using cdrecord-2.01.01.0.a03-1.1, kernel 2.6.15-1.1819_FC5:

launching command: cdrecord fs=16m dev=/dev/hdb -eject -dao driveropts=burnfree
-v -data -nopad /home/data/image.iso.N1LaDg
cdrecord stderr: cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord stderr: cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord stderr: cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord stderr: cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
cdrecord stderr: cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord stderr: scsidev: '/dev/hdb'
cdrecord stderr: devname: '/dev/hdb'
cdrecord stderr: scsibus: -2 target: -2 lun: -2
cdrecord stderr: Linux sg driver version: 3.5.27
cdrecord stderr: cdrecord: Warning: using inofficial libscg transport code
version (schily - Red Hat-scsi-linux-sg.c-1.85-RH '@(#)scsi-linux-sg.c      
1.85 05/05/16 Copyright 1997 J. Schilling').
cdrecord stderr: SCSI buffer size: 64512
cdrecord stdout: Cdrecord-Clone 2.01.01a03-dvd (i686-pc-linux-gnu) Copyright (C)
1995-2005 Jörg Schilling
cdrecord stdout: NOTE: This version contains the OSS DVD extensions for cdrtools
and thus may
cdrecord stdout:       have bugs related to DVD issues that are not present in
the original
cdrecord stdout:       cdrtools. Please send bug reports or support requests to
cdrecord stdout:       http://bugzilla.redhat.com/bugzilla The original cdrtools
author should
cdrecord stdout:       not be bothered with problems in this version.
cdrecord stdout: TOC Type: 1 = CD-ROM
cdrecord stdout: Using libscg version 'schily-0.8'.
cdrecord stdout: Driveropts: 'burnfree'
cdrecord stdout: atapi: 1
cdrecord stdout: Device type    : Removable CD-ROM
cdrecord stdout: Version        : 0
cdrecord stdout: Response Format: 2
cdrecord stdout: Capabilities   :
cdrecord stdout: Vendor_info    : '_NEC    '
cdrecord stdout: Identifikation : 'DVD_RW ND-3500AG'
cdrecord stdout: Revision       : '2.16'
cdrecord stdout: Device seems to be: Generic mmc2 DVD-R/DVD-RW.
cdrecord stdout: Current: 0x0009
cdrecord stdout: Profile: 0x002B
cdrecord stdout: Profile: 0x001B
cdrecord stdout: Profile: 0x001A
cdrecord stdout: Profile: 0x0014
cdrecord stdout: Profile: 0x0013
cdrecord stdout: Profile: 0x0011
cdrecord stdout: Profile: 0x0010
cdrecord stdout: Profile: 0x000A
cdrecord stdout: Profile: 0x0009 (current)
cdrecord stdout: Profile: 0x0008 (current)
cdrecord stdout: Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
cdrecord stdout: Driver flags   : MMC-3 SWABAUDIO BURNFREE
cdrecord stdout: Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
cdrecord stderr: cdrecord: Operation not permitted. Cannot send SCSI cmd via ioctl
cdrecord stdout: Drive buf size : 1343488 = 1312 KB
cdrecord stdout: FIFO size      : 16777216 = 16384 KB
cdrecord stdout: Track 01: data   700 MB
cdrecord stdout: Total size:      804 MB (79:42.57) = 358693 sectors
cdrecord stdout: Lout start:      804 MB (79:44/43) = 358693 sectors
process stdout: HUP

Note You need to log in before you can comment on or make changes to this bug.