Bug 176573 - iconv is crashing in nroff
iconv is crashing in nroff
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 176583 177124 177126 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-26 16:04 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.3.90-25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 02:45:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2005-12-26 16:04:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
When running man command iconv is segfaulting in nroff script. For example
if I try execute the command on manpage of man command:

# nroff -mandoc man.1
/usr/bin/nroff: line 69: 17905 Done                    /usr/bin/iconv -f ${charset_in} -t utf-8 ${TMPFILE}
     17906                       | /usr/bin/groff -mtty-char -Tutf8 $opts 2>/dev/null
     17907 Segmentation fault      | /usr/bin/iconv -f utf-8 -t ${charset_out}//translit

The same command just outputs the formatted man page when working.

Version-Release number of selected component (if applicable):
glibc-common-2.3.90-22

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to latest rawhide
2. Get a uncompressed man page of something
3. execute nroff -mandoc something.1
  

Additional info:
Comment 1 Jakub Jelinek 2005-12-27 08:16:19 EST
Can't reproduce, so you need to provide more details.
What locale are you using (say output from locale command is good enough),
what exact man page you can reproduce it on (attach to the bug report).
Comment 2 Sammy 2005-12-27 09:44:50 EST
Hi,

Below is the output of locale. This happens on every man page.
Also, I am on x86_64. Also, my /etc/sysconfig/i18n file:

LANG="en_US"
SYSFONT="latarcyrheb-sun16"
SUPPORTED="en_US.UTF-8:en_US:en"

=============================================================
$ locale
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE="en_US"
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
Comment 3 Sammy 2005-12-27 09:46:04 EST
Hi,

Below is the output of locale. This happens on every man page.
Also, I am on x86_64. Also, my /etc/sysconfig/i18n file:

LANG="en_US"
SYSFONT="latarcyrheb-sun16"
SUPPORTED="en_US.UTF-8:en_US:en"

=============================================================
$ locale
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE="en_US"
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
Comment 4 Sammy 2005-12-27 09:53:15 EST
OK...playing around found that the following fixes it:

# cat i18n
LC_ALL="en_US.UTF-8"
LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"

I had changed this at some point to some other bug BUT I don't think iconv
should segfault with the above.
Comment 5 Ulrich Drepper 2005-12-28 19:46:18 EST
*** Bug 176583 has been marked as a duplicate of this bug. ***
Comment 6 Ulrich Drepper 2005-12-28 19:48:04 EST
Should be fixed in the next rawhide release by

2005-12-27  Jakub Jelinek  <jakub@redhat.com>

        * iconv/gconv_trans.c (__gconv_transliterate): Demangle step __fct
        before calling it.
Comment 7 Robert Scheck 2005-12-29 17:30:18 EST
Okay, glibc-2.3.90-23 (built from Fedora CVS) just works for me - at least my 
bug reported in #176583 disappeared now.
Comment 8 Jakub Jelinek 2006-01-03 02:45:45 EST
Today's rawhide will include glibc-2.3.90-25.
Comment 9 Jakub Jelinek 2006-01-06 11:43:05 EST
*** Bug 177124 has been marked as a duplicate of this bug. ***
Comment 10 Jakub Jelinek 2006-01-06 11:43:46 EST
*** Bug 177126 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.