Bug 177126 - "/usr/bin/iconv -f utf-8 -t iso-8859-1//translit file" crashes
"/usr/bin/iconv -f utf-8 -t iso-8859-1//translit file" crashes
Status: CLOSED DUPLICATE of bug 176573
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 10:26 EST by Ville Herva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 11:43:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Herva 2006-01-06 10:26:16 EST
From Bugzilla Helper:
User-Agent: Opera/9.00 (X11; Linux i686; U; en)

Description of problem:
I can no longer view any man pages. I traced it down to 
running

cd /usr/share/man && (echo ".ll 13.6i"; echo ".nr LL 13.6i"; echo ".pl 1100i"; /
usr/bin/gunzip -c '/usr/share/man/man1/xine.1.gz'; echo ".\\\""; echo ".pl \n
(nlu+10") | /usr/bin/gtbl | /usr/bin/nroff -c --legacy ISO-8859-1 -mandoc 2>/dev
/null | iconv -f utf-8 -t latin1//translit | less

and "/usr/bin/nroff -c --legacy ISO-8859-1 -mandoc"
running

| /usr/bin/groff -mtty-char -Tutf8 $opts 2>/dev/null                 
| /usr/bin/iconv -f utf-8 -t ${charset_out}//translit

and "/usr/bin/iconv -f utf-8 -t ${charset_out}//translit" crashes.

Try
/usr/bin/iconv -f utf-8 -t iso-8859-1//translit file
with the attached file.

Under gdb, I get

Program received signal SIGSEGV, Segmentation fault.
                                                                      
0xdd86b36b in ?? ()
                                                                                                                                     

(gdb) bt
                                                                                                                                                
#0  0xdd86b36b in ?? ()
                                                                                                                             

#1  0x41b129d7 in __gconv_transliterate () from /lib/libc.so.6            
#2  0xb7d647ed in gconv () from /usr/lib/gconv/ISO8859-1.so
                                                                                             
#3  0x41b110d3 in __gconv_transform_utf8_internal () from /lib/libc.so.6
                       
#4  0x41b0bd03 in __gconv () from /lib/libc.so.6
                                                            
#5  0x41b0b33a in iconv () from /lib/libc.so.6
                                                
#6  0x08049b51 in ?? ()
                                                                                        

#7  0x08055c78 in ?? ()
                                                                                                                    

#8  0xbfbb8e4c in ?? ()
                                                                                   

#9  0xbfbb8e48 in ?? ()
                                                                                       

#10 0xbfbc0e54 in ?? ()
                                                                                                                                 

#11 0xbfbc0e50 in ?? ()
                                                                               
#12 0x08055c78 in ?? ()
                                                                                                                                 

#13 0xb7fbd000 in ?? ()
                                                                                                                                 

#14 0x00000000 in ?? ()
                                                                



Version-Release number of selected component (if applicable):
glibc-common-2.3.90-22

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  


Additional info:

I found out that I can workaround the original man(1) problem by changing

                                                 
  LC_CTYPE=fi_FI@euro
to
  LC_CTYPE=""

(which makes nroff not to execute the intermediate iconv step.)
Comment 1 Jakub Jelinek 2006-01-06 11:43:30 EST

*** This bug has been marked as a duplicate of 176573 ***

Note You need to log in before you can comment on or make changes to this bug.