Bug 1765734 - [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-default token max age to generate tokens that expire shortly works as expected when using a code authorization flow
Summary: [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-defa...
Keywords:
Status: CLOSED DUPLICATE of bug 1765733
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Stefan Schimanski
QA Contact: scheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-25 20:12 UTC by Anurag saxena
Modified: 2019-11-06 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 13:21:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Anurag saxena 2019-10-25 20:12:39 UTC
Description of problem:

fail [github.com/openshift/origin/test/extended/oauth/expiration.go:30]: Unexpected error:
    <*errors.errorString | 0xc000288100>: {
        s: "timed out waiting for the condition",
    }
    timed out waiting for the condition
occurred

Additional info:
https://testgrid.k8s.io/redhat-openshift-release-4.3-informing-ocp#release-openshift-ocp-installer-e2e-azure-4.3
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-azure-4.3/243

Comment 1 Michal Fojtik 2019-11-06 13:21:14 UTC

*** This bug has been marked as a duplicate of bug 1765733 ***


Note You need to log in before you can comment on or make changes to this bug.