Bug 176577 - klauncher doesn't know protocol audiocd
Summary: klauncher doesn't know protocol audiocd
Status: CLOSED DUPLICATE of bug 176637
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-26 23:35 UTC by Tobias Oed
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 14:56:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC file for patching kdemultimedia-3.5.1-0.1.fc4 Source-RPM (479 bytes, patch)
2006-02-22 13:18 UTC, Daniel Paul
no flags Details | Diff

Description Tobias Oed 2005-12-26 23:35:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Both kaudiocreator (from kdemultimedia-3.5.0-0.1.fc4) and 
amarok-1.3.7-1.fc4 fail when trying to access a cdrom with
the error message

Could not start process Unable to create io-slave:
klauncher said: Unknown protocol 'audiocd'.

Strangely kscd seems to work.
Tobias.


Version-Release number of selected component (if applicable):
kdelibs-3.5.0-0.2.fc4

How reproducible:
Always

Steps to Reproduce:
1. put a cd in the cdrom drive
2. start kaudiocreator
3. try to rip the cd
  

Actual Results:  The program gives an error message and sometimes segfaults

Expected Results:  It rips the cd :)

Additional info:

Comment 1 Tobias Oed 2005-12-31 18:08:53 UTC
I should have filed this against kdemultimedia. 
The audiocd kioslave doesn't get build because a header file 
isn't found.
I got it to work by rebuilding the rpm after applying this patch to
mdemultimedia.spec
166,167c166
<            --disable-xaw \
<            --with-extra-includes=/usr/include/cdda/
---
>            --disable-xaw
HTH Tobias


Comment 2 Daniel Paul 2006-02-22 13:18:50 UTC
Created attachment 125024 [details]
SPEC file for patching kdemultimedia-3.5.1-0.1.fc4 Source-RPM

This is a SPEC file for patching the kdemultimedia Source-RPM. Download
Source-RPM, recompile and install as described in duplicate bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176637

One of these bugs should be marked as a duplicate...

Comment 3 Ngo Than 2006-02-22 14:56:49 UTC

*** This bug has been marked as a duplicate of 176637 ***


Note You need to log in before you can comment on or make changes to this bug.