Bug 176637 - kaudiocreator : unknown protocol : audiocd
kaudiocreator : unknown protocol : audiocd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
: 176577 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-28 04:00 EST by Pierre Juhen
Modified: 2007-11-30 17:11 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 09:56:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for SPEC file of kdemultimedia SRPM, to be used by rpmbuild instead (969 bytes, patch)
2006-01-07 10:30 EST, Daniel Paul
no flags Details | Diff
Simplified SPEC file patch (359 bytes, patch)
2006-01-08 01:37 EST, Stephan Groß
no flags Details | Diff
Patch for SPEC-File of kdemultimedia-3.5.1-0.1.fc4 (479 bytes, patch)
2006-02-22 06:24 EST, Daniel Paul
no flags Details | Diff

  None (edit)
Description Pierre Juhen 2005-12-28 04:00:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; fr-FR; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I lauch a CD ripping (ogg), all the subtask (one per track) fails with the message "Unknown protocol : audiocd" (a dialog window per track).

Version-Release number of selected component (if applicable):
kdemultimedia-3.5.0-0.1.fc4

How reproducible:
Always

Steps to Reproduce:
1.Insert a CD 
2.Lauch kaudiocreator
3.Launch the ripping
  

Actual Results:  Error windows

Expected Results:  Ripping in ogg format

Additional info:
Comment 1 Daniel Paul 2005-12-29 10:21:31 EST
I will throw in a "me too" (on i686) and try to explain the problem a little 
further: konqueror shows the same result ("audiocd: Protocol unknown") when I 
insert an audio-cd into the cdrom drive 
 
The reason is IMHO, that the library kio_audiocd.so is missing in 
kdemultimedia-3.5.0-0.1.fc4 package. Maybe anything shows up at bugs.kde.org, 
for example that the kio_audiocd source does not belong to the package 
kdemultimedia anymore (There were reports about crashing KDE 3.5 RC1 by using 
kio_audiocd?) 
 
Comment 2 Michel Ludwig 2005-12-29 14:50:39 EST
The kio_audiocd source is still in kdemultimedia: 
 
http://websvn.kde.org/tags/KDE/3.5.0/kdemultimedia/kioslave/audiocd/ 
 
Probably it's related to some missing or wrong compilation flag. 
Comment 3 Jari Mäkelä 2006-01-03 05:37:08 EST
I have similar problems with kdemultimedia-3.5.0-0.1.fc4. KAudioCreator crashes
when I start the ripping process of a CD showing the "audiocd: Protocol unknown"
error popup first. Downgrading to 3.4.2-0.fc4.1 removed the problem.
Comment 4 Jari Mäkelä 2006-01-03 05:49:44 EST
The severity should be "High" as the bug crashes kaudiocreator.
Comment 5 Daniel Paul 2006-01-07 10:30:29 EST
Created attachment 122908 [details]
patch for SPEC file of kdemultimedia SRPM, to be used by rpmbuild instead

I've recompiled kdemultimedia from standard Fedora SRPM, using a patched 
specfile. Works for me now, patch is attached. Steps to use are as follows (I 
won't post a whole RPM here for I hope the package gets updated soon): 
 
- Download Source-RPM:
<MIRROR>/updates/4/SRPMS/kdemultimedia-3.5.0-0.1.fc4.src.rpm 
- Create the directory ~/rpmbuild (in your home directory), if it not already 
exists: mkdir ~/rpmbuild
- Install the Source-RPM: rpm -i <filename>
- Change to SPECS directory: cd ~/rpmbuild/SPECS 
- save attachment (patch) into ~/rpmbuild/SPECS 
- Patch SPEC file: patch -p0 <kdemultimedia.spec.patch 
- Build kdemultimedia: rpmbuild -bb kdemultimedia.spec 
 
Running rpmbuild of kdemultimedia may produce several BuildRequires warnings 
for needed RPMS. Install these (using yum install <package>). 
 
The final RPM is at ~/rpmbuild/RPMS/i386/kdemultimedia-3.5.0-0.2.fc4.i386.rpm, 

you can update your kdemultimedia installation using rpm -U <filename>. 
 
audiocd:/ protocol works for me now ;-)
Comment 6 Stephan Groß 2006-01-08 01:37:12 EST
Created attachment 122917 [details]
Simplified SPEC file patch

I have added a simpliefied version of the SPEC file patch. The problem during  

the build process seems to be that the cdda header files are placed  
in /usr/include/cdda. Thus, they are not found by the configure script. Simple 

solution: use the --with-extra-includes directive to announce the cdda
directory to the configure script (see my patch).
Comment 7 Daniel Paul 2006-01-08 05:41:10 EST
I think beside the missing header files there is no command to actually compile 
the kioslave_audiocd, because there is NO compile error if I don't have the 
lines

make $SMP_MFLAGS -C kioslave/audiocd/kcmaudiocd
and
make -C kioslave/audiocd/kcmaudiocd DESTDIR=$RPM_BUILD_ROOT install

in the appropriate %build% and %install% section.

Maybe the build fails silently (?). If that would be the case, my patch would 
contain one line only too (export USERINCLUDES="/usr/include/cdda").

If you patch a specfile, it is wise to increment the version number somewhere, 
because yum/rpm fails to update any package with the same version until you 
specify the --force option.

Comment 8 Daigoro Toyama 2006-01-11 23:36:53 EST
Thanks, Daniel Paul, for the patch file. I was having the exact same issue with
kio_audiocd (FC4 for i686). I used your patch to rebuild the kdemultimedia
packages. CD ripping is now working well.
Comment 9 Stephan Groß 2006-02-05 09:09:43 EST
What about the proposed patches? Are they not worth to be considered for 
inclusion into the stable release? kdemultimedia version 3.5.1 has just been 
released without fixing the mentioned problems with the kio_audiocd slave :-( 
Comment 10 Antti Andreimann 2006-02-05 23:15:06 EST
#176577 Has a proper patch for configure line in the SPEC file.
Comment 11 Daniel Paul 2006-02-06 11:04:43 EST
Bug 176577 is a duplicate of this bug and should be marked as such (or vice   
versa) by the maintainer for this "kind" of bugs. The patch for the spec file   
does exactly the same as the patches posted in comments 5 or 6 of this bug. So  
please, Antti, read the comments of a bug first before adding an additional  
comment to it ;-)  
  
Basically... I am wondering: Why is there no comment at all by the "Assigned  
to" person for this bug??? 
 
Greetings! 
...and keep on patching anyway 
Comment 12 Daniel Paul 2006-02-22 06:24:38 EST
Created attachment 125017 [details]
Patch for SPEC-File of kdemultimedia-3.5.1-0.1.fc4

This is a simple patch for the spec file of kdemultimedia-3.5.1-0.1.fc4
Source-RPM. Just download, recompile, install, rip again... (as described in
one of my posts above).

Maybe ripping out of the box works in KDE 4 (or 5) again ;-)
Comment 13 Ngo Than 2006-02-22 09:56:04 EST
I've been very busy lately, sorry for delay here. I will build new kdemultimedia
including this patch into FC4 update this week. Thanks for your reports,
Comment 14 Ngo Than 2006-02-22 09:56:56 EST
*** Bug 176577 has been marked as a duplicate of this bug. ***
Comment 15 Daigoro Toyama 2006-02-22 11:22:49 EST
Hi Ngo.

Thanks! Just curious, is the new RPM going to be labelled as 3.5.1-0.2.fc4?
Comment 16 Daniel Paul 2006-02-22 12:06:52 EST
Hi Daigoro, 
 
in the specfile patch I included a new version number (named as above) for 
it's easier to install (no complains by rpm command about conflicts). 
Comment 17 Ngo Than 2006-02-22 12:12:45 EST
yes, it should be 3.5.1-0.2.fc4
Comment 18 Daigoro Toyama 2006-02-22 12:28:35 EST
Hi Paul.

Yes, I am aware of that. That is why I asked Than the question. If the new
official RPM is labelled 3.5.1-0.2.fc4 as he just indicated, I will need to make
sure I check its availability using "yum list available kdemultimedia" instead
of "yum check-update" because the latter would not catch it.

Note You need to log in before you can comment on or make changes to this bug.