Bug 1766107 - etcd image version is not set to the latest one but sticks to 3.2.22 [NEEDINFO]
Summary: etcd image version is not set to the latest one but sticks to 3.2.22
Keywords:
Status: CLOSED DUPLICATE of bug 1744900
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 3.11.0
Hardware: Unspecified
OS: All
high
high
Target Milestone: ---
: 3.11.z
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-28 09:53 UTC by Joel Rosental R.
Modified: 2020-03-10 12:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-10 12:26:10 UTC
Target Upstream Version:
emahoney: needinfo? (sbatsche)


Attachments (Terms of Use)

Description Joel Rosental R. 2019-10-28 09:53:38 UTC
Description of problem:
When OCP 3.11.146 is installed it uses an outdated etcd image version (3.2.22) which seems to come from:

/usr/share/ansible/openshift-ansible/roles/etcd/defaults/main.yaml:r_etcd_default_version: "3.2.22"

Same when a cluster is upgraded, the etcd image version is not updated to the latest one available (currently 3.2.26-16).


Version-Release number of the following components:
rpm -q openshift-ansible
openshift-ansible-3.11.146-1.git.0.fcedb45.el7.noarch

rpm -q ansible
ansible-2.6.19-1.el7ae.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install a new cluster and check the image version the etcd pods are using
2. Update a cluster and check the image version the etcd pods are using

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:
/etc/origin/node/pods/etcd.yaml should point to the latest image available in order to not deliver an outdated image version.

Additional info:

Comment 1 Russell Teague 2019-10-28 13:08:33 UTC
APIserver Team,
Should the version of etcd be updated or is this still the correct version to be installed for 3.11?
https://github.com/openshift/openshift-ansible/blob/release-3.11/roles/etcd/defaults/main.yaml#L10

Comment 4 Scott Dodson 2020-03-10 12:26:10 UTC
This was already fixed in Bug 1744900 which shipped via https://access.redhat.com/errata/RHBA-2020:0402

*** This bug has been marked as a duplicate of bug 1744900 ***


Note You need to log in before you can comment on or make changes to this bug.