Bug 176674 - [PATCH] libXScrnSaver-devel has broken dependencies
Summary: [PATCH] libXScrnSaver-devel has broken dependencies
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libXScrnSaver   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL: http://www.redhat.com/archives/fedora...
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks: 176614
TreeView+ depends on / blocked
 
Reported: 2005-12-29 11:47 UTC by Dawid Gajownik
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.0.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 03:35:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to the spec file (1.17 KB, patch)
2005-12-29 11:52 UTC, Dawid Gajownik
no flags Details | Diff

Description Dawid Gajownik 2005-12-29 11:47:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051217 SeaMonkey/1.5a

Description of problem:
Please see â http://www.redhat.com/archives/fedora-test-list/2005-December/msg00724.html for more information.

Version-Release number of selected component (if applicable):
 libXScrnSaver-1.0.0-1

How reproducible:
Always

Steps to Reproduce:
1. Run `fedora-rmdevelrpms' from fedora-rpmdevtools package
2. yum install libXScrnSaver-devel
3. pkg-config --libs xscrnsaver
  

Additional info:

This bug blocks update of gajim in FE.

Comment 1 Dawid Gajownik 2005-12-29 11:52:48 UTC
Created attachment 122627 [details]
patch to the spec file

Comment 2 Mike A. Harris 2006-01-09 17:07:23 UTC
Just so the problem is 100% documented directly in bugzilla, here is a cut
and paste of the mail message linked to above:

-------------------------------------------------------
[libXScrnSaver] Is âRequires.privateâ real ly needed?

    * From: Dawid Gajownik <gajownik fedora pl>
    * To: For testers of Fedora Core development releases <fedora-test-list
redhat com>
    * Subject: [libXScrnSaver] Is âRequires.privateâ real ly needed?
    * Date: Sat, 24 Dec 2005 16:25:38 +0100

Hi!


I wanted to update gajim in Fedora Extras but libXScrnSaver-devel has broken
dependencies. `pkg-config --libs xscrnsaver' command gives this output:

Package x11 was not found in the pkg-config search path.
Perhaps you should add the directory containing `x11.pc'
to the PKG_CONFIG_PATH environment variable
Package 'x11', required by 'XScrnSaver', not found


Before reporting this in Bugzilla I wanted to ask about one question.
/usr/lib/pkgconfig/xscrnsaver.pc file contains this line:

Requires.private: x11 xext


If I understand pkg-config's manpage correctly, âRequires.privateâ and
âLibs.privateâ are only needed in the case of static linking. Am I right? If
yes, maybe it would be better to comment this line out to not to add unnecessary
dependency bloat? (X.org X11 libs in Rawhide do not provide static libs.) Here's
the proposal patch â http://wiki.fedora.pl/gajownik/xorg/libXScrnSaver-private.patch

Comments?

BTW Merry Christmas!



Comment 3 Mike A. Harris 2006-01-17 03:35:22 UTC
Fixed in the 1.0.0-2 release


Note You need to log in before you can comment on or make changes to this bug.