Bug 176614 - New version 0.9.1 available
New version 0.9.1 available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gajim (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dawid Gajownik
Fedora Extras Quality Assurance
:
Depends On: 176653 176674
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-27 12:21 EST by Eric Tanguy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 09:52:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Tanguy 2005-12-27 12:21:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:


Version-Release number of selected component (if applicable):
gajim-0.8.2-1.fc4

How reproducible:
Always

Steps to Reproduce:
1.start gajim 
2.
3.
  

Actual Results:  see version 0.8.2

Expected Results:  see version 0.9.1

Additional info:
Comment 1 Dawid Gajownik 2005-12-27 12:39:18 EST
Thanks for your bug report!

I'm working on it but there are two small problems. There is new dependency --
pysqlite 2.x which is not available in Fedora Extras and libXScrnSaver-devel in
Rawhide has broken dependencies →
http://www.redhat.com/archives/fedora-test-list/2005-December/msg00724.html
Comment 2 Eric Tanguy 2006-01-13 16:39:08 EST
No more news about it ?
Comment 3 Dawid Gajownik 2006-01-14 07:30:46 EST
(In reply to comment #2)
> No more news about it ?

Unfortunately, no. No one was interested in reviewing python-sqlite2 (bug #176653).
Comment 4 Dawid Gajownik 2006-01-15 11:38:06 EST
Good news -- python-sqlite2 was accepted and gajim 0.9.1 should be available in
a short time in fedora-development-extras (buildsystem is broken right now):

[y4kk0@X devel]$ make plague
/usr/bin/plague-client build gajim gajim-0_9_1-1_fc5 devel
Package gajim enqueued.  (However, no Job ID was provided in the time required)
[y4kk0@X devel]$

If nothing goes wrong, I'll update gajim in FC-4 after a week.
Comment 5 Dawid Gajownik 2006-01-23 18:08:24 EST
Aghh, python-sqlite2 does not work on FC-4, because it requires newer sqlite
version :/ If upgrade of sqlite is not possible (bug #178681), I will need to
downgrade python-sqlite2 in Fedora Extras 4.

This package does not like me... ;-)
Comment 6 Eric Tanguy 2006-02-04 14:23:56 EST
some news ?
Comment 7 Dawid Gajownik 2006-02-04 15:59:30 EST
sqlite in FC-4 will not be updated to newer version so I need to downgrade
python-sqlite2 in FE-4. I asked on fedora-extras-list about it →
http://www.redhat.com/archives/fedora-extras-list/2006-February/msg00235.html If
there is no answer till tomorrow, I'll push new package through buildsystem
(changes are already in CVS). New gajim rpm should follow in 2-3 days.

I'm really sorry that it takes so long. This new dependency caused so much
problems :( I hope that you understand this situation. It's a bit similar to
your qucs package and freehdl. Sometimes it's really hard to get a review or an
answer.
Comment 8 Dawid Gajownik 2006-02-04 19:26:20 EST
> New gajim rpm should follow in 2-3 days.

This will take a bit longer :/ I've made few tests with a friend and upgrade
from 0.8.2 to 0.9.1 breakes user profile (application crashes). The only
workaround now is to remove ~/.gajim directory. I will need to contact with
upstream...
Comment 9 Dawid Gajownik 2006-02-15 19:29:44 EST
> upgrade from 0.8.2 to 0.9.1 breakes user profile (application crashes).

I was wrong. The cause of gajim crash is DBUS_SESSION_BUS_ADDRESS variable →
http://trac.gajim.org/ticket/1566
Comment 10 Eric Tanguy 2006-02-16 16:48:15 EST
If it seems to have problems with DBUS in FC4, why to not disable DBUS support
in gajim 0.9.1 in FC4 and enable it in devel ?
Comment 11 Dawid Gajownik 2006-02-16 17:05:14 EST
Yes, I've been thinking about it. I don't know why, but `gajim-remote' does not
work in rawhide, too. I'm not shure whether it's problem with DBUS or with my
system. I wanted at first to reinstall rawhide and then retest gajim.
Unfortunately, I was not able to perform installation because there are always
some problems (for instance #177848, #179992, #181585) ;-)

I'll try to do this tonight and will see whether the problem is caused by too
old dbus package.
Comment 12 Dawid Gajownik 2006-02-17 09:52:23 EST
gajim-0.9.1 without D-BUS support was built few minutes ago in FE-4. gajim in
Rawhide works fine -- my system was broken ;-)

Note You need to log in before you can comment on or make changes to this bug.