Bug 1766750 - Sorting by any key in an operator's resource tab throws react Invariant Violation
Summary: Sorting by any key in an operator's resource tab throws react Invariant Viola...
Keywords:
Status: CLOSED DUPLICATE of bug 1761879
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-29 19:40 UTC by Jose R. Gonzalez
Modified: 2019-10-30 14:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-30 14:13:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1761879 0 unspecified CLOSED Resources Tab under Custom Resource details page for installed operator crashes 2021-02-22 00:41:40 UTC

Description Jose R. Gonzalez 2019-10-29 19:40:40 UTC
Description of problem: 

In dashboard, attempting to sort the list of resources associated with a given instance of a CR throws an error. Removing the sort params added to my URL string brings me back to the resources page.

Tested with a dev operator I was working on as well as Service Mesh "ServiceMeshControlPlane" resource. 

Version-Release number of selected component (if applicable):
OCP 4.2.0-0.nightly-2019-09-02-172410


How reproducible:
100%


Steps to Reproduce:
1. In Dashboard Administrator View, Click "Operators" Dropdown > "Installed Operators"
2. Pick any operator that has an installed operand and click its "Provided API".
3. Click "Resources" to list operand resources
4. Select any sort key (such as "Name", "Kind", ...)

Actual results:
Minified React Error #185
https://reactjs.org/docs/error-decoder.html/?invariant=185



Expected results:
Expected sorting of the data by the listed key.



Additional info:
Seems very similar to https://bugzilla.redhat.com/show_bug.cgi?id=1761879 but the incantation differs so it's unclear if they're related issues.

Comment 1 Jose R. Gonzalez 2019-10-29 20:47:18 UTC
Tested in a 4.3.x nightly build and it seems to be resolved there. Might be acceptable to close this if there's no further action needed.

Comment 2 Samuel Padgett 2019-10-30 14:13:53 UTC
Yes, this will be fixed by https://github.com/openshift/console/pull/2981 when it merges. Marking as a duplicate of Bug 1761879.

*** This bug has been marked as a duplicate of bug 1761879 ***


Note You need to log in before you can comment on or make changes to this bug.