Bug 176704 - installonlyn: fluctuating no of kernels present
installonlyn: fluctuating no of kernels present
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
: 176705 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-12-30 07:40 EST by jan vestby
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 18:20:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jan vestby 2005-12-30 07:40:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5) KHTML/3.5.0 (like Gecko)

Description of problem:
setting the onlyn to e.g 5 result in installation of 4 kernels. On  
installation of the 5th every already installed kernel but the running kernel  
in removed.  
I think this is due to the design of the break condition in the 
postresolve_hook function in installonlyn.  
The variable numleft will already be 0 before decrementing when on 
installation of the last kernel of the preselected set size. 
  
   

Version-Release number of selected component (if applicable):
2.5.0.5

How reproducible:
Sometimes

Steps to Reproduce:
1. set to_keep=4 (/etc/yum/pluginconf.d/installonlyn.conf) 
2. install a kernel (no 1, in adition to the running kernel)  
3. install a kernel (no 2)  
4. install a kernel (no 3)  
     

Actual Results:  Only 2 kernels are installed (the running + the newest) 

Expected Results:  The preset to_keep number of kernels present: only the oldest dropped   
when the "desired" count would have been exceeded.  

Additional info:

reproducibility: this happens on istallation of every (n-1)'th kernel (with  
to_keep=n) - if I got the arithmetic right.
Comment 1 Jeremy Katz 2005-12-30 11:28:12 EST
*** Bug 176705 has been marked as a duplicate of this bug. ***
Comment 2 Robert Nichols 2006-02-14 09:36:28 EST
Bump.  This bug is still present in yum-2.5.1-5 .
My /etc/yum/pluginconf.d/installonlyn.conf contains:

    [main]
    enabled=0
    # this sets the number of package versions which are kept
    tokeep=5

Today's rawhide update would have wiped out all my backup kernels.

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel                  i686       2.6.15-1.1948_FC5  development        13 M
 kernel-devel            i686       2.6.15-1.1948_FC5  development       4.7 M
...
Removing:
 kernel                  i686       2.6.15-1.1928_FC5  installed          33 M
 kernel                  i686       2.6.15-1.1917_FC5  installed          33 M
 kernel                  i686       2.6.15-1.1915_FC5  installed          33 M
 kernel-devel            i686       2.6.15-1.1915_FC5  installed          14 M
 kernel-devel            i686       2.6.15-1.1917_FC5  installed          14 M
 kernel-devel            i686       2.6.15-1.1928_FC5  installed          13 M

Transaction Summary
=============================================================================
Install      2 Package(s)
Update     113 Package(s)
Remove       6 Package(s)
Total download size: 189 M
Is this ok [y/N]: n
Exiting on user Command
Complete!

Comment 3 Robert Nichols 2006-02-14 09:56:48 EST
Sorry, that "enabled=0" line should have read "enabled=1".
I cut 'n pasted the file that I modified to let yum run
the update without losing my kernels.
Comment 4 Jeremy Katz 2006-02-24 18:20:03 EST
Hah, dumb bug.  Fixed in CVS, will be in 2.5.3-2

Note You need to log in before you can comment on or make changes to this bug.