Bug 176705 - installonlyn: fluctuating no of kernels present
installonlyn: fluctuating no of kernels present
Status: CLOSED DUPLICATE of bug 176704
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 07:41 EST by jan vestby
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-30 11:27:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jan vestby 2005-12-30 07:41:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5) KHTML/3.5.0 (like Gecko)

Description of problem:
setting the onlyn to e.g 5 result in installation of 4 kernels. On  
installation of the 5th every already installed kernel but the running kernel  
in removed.  
I think this is due to the design of the break condition in the 
postresolve_hook function in installonlyn.  
The variable numleft will already be 0 before decrementing when on 
installation of the last kernel of the preselected set size. 
  
   

Version-Release number of selected component (if applicable):
2.5.0.5

How reproducible:
Sometimes

Steps to Reproduce:
1. set to_keep=4 (/etc/yum/pluginconf.d/installonlyn.conf) 
2. install a kernel (no 1, in adition to the running kernel)  
3. install a kernel (no 2)  
4. install a kernel (no 3)  
     

Actual Results:  Only 2 kernels are installed (the running + the newest) 

Expected Results:  The preset to_keep number of kernels present: only the oldest dropped   
when the "desired" count would have been exceeded.  

Additional info:

reproducibility: this happens on istallation of every (n-1)'th kernel (with  
to_keep=n) - if I got the arithmetic right.
Comment 1 jan vestby 2005-12-30 10:21:08 EST
duplicate of 176704. sorry 
 
Comment 2 Jeremy Katz 2005-12-30 11:27:59 EST

*** This bug has been marked as a duplicate of 176704 ***

Note You need to log in before you can comment on or make changes to this bug.