Bug 176726 - non-LUKS cryptsetup is broken
non-LUKS cryptsetup is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
: 181621 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 19:02 EST by Russell Coker
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.0.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 12:27:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2005-12-30 19:02:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
cryptsetup -d /etc/key create test_crypt /dev/temp/test

I have a key file named /etc/key for encrypting/decrypting partitions.  I try to encrypt an LVM volume named /dev/temp/test with the above cryptsetup command and get the following error:

Command failed: Invalid argument

In version 1.0.1-3 it worked perfectly.

The code in the dm_query_device() function doesn't seem to match the recent device-mapper code in that it passws a NULL for the "next" variable which seems inappropriate.  Maybe an interface change in the library code it's linked to?

Version-Release number of selected component (if applicable):
1.0.1-4.1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Clemens Fruhwirth 2006-01-11 04:41:33 EST
Maybe this is because of a different libdevmapper library?
Can you send me the source diffs between 1.0.1-3 and 1.0.1-4? Thanks
Comment 2 W. Michael Petullo 2006-02-02 18:55:38 EST
I also see this problem.  The cryptsetup-luks-1.0-1 package from Fedora Core 4
works fine.  Using cryptsetup-luks-1.0.1-4.1 causes:

# cryptsetup create foo /dev/sda1
Command failed: Invalid argument
Comment 3 Clemens Fruhwirth 2006-02-03 04:17:15 EST
Peter, any progress on this bug?
Comment 4 Clemens Fruhwirth 2006-02-21 06:46:20 EST
See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=344313

Fixed in cryptsetup-luks 1.0.2, which was released today. http://luks.endorphin.org
Comment 5 Bill Nottingham 2006-02-21 12:10:14 EST
*** Bug 181621 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2006-02-21 12:27:55 EST
1.0.2-1 built.

Note You need to log in before you can comment on or make changes to this bug.