Bug 181621 - Cryptsetup create: Command failed: Invalid argument
Cryptsetup create: Command failed: Invalid argument
Status: CLOSED DUPLICATE of bug 176726
Product: Fedora
Classification: Fedora
Component: cryptsetup (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2006-02-15 10:34 EST by Daniel Riek
Modified: 2014-03-16 22:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 12:09:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2006-02-15 10:34:56 EST
Description of problem:
The attempt to create a crypted device mapping via cryptsetup fails with an
unclear errormessage

Version-Release number of selected component (if applicable):
FC5T2 versions and newest rawhide...

How reproducible:

Steps to Reproduce:
Following the steps in several howtos:
1.[root@scorp opt]# dd if=/dev/zero of=dmcrypttest bs=1024 count=10000
2.[root@scorp opt]# losetup /dev/loop0 dmcrypttest
3.[root@scorp opt]# cryptsetup create crypt1 /dev/loop0

Actual results:
Command failed: Invalid argument

Expected results:
Crypted dm mapping with name crypt1 created

Additional info:
Same results if I manually load dm-crypt and aes modules, create partitions, try
it on a lvm logical volume, specify crypto algorithm...
Comment 1 Rahul Sundaram 2006-02-20 05:56:05 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Oskari Saarenmaa 2006-02-21 06:04:32 EST
This is probably a duplicate of #176726.
Comment 3 Bill Nottingham 2006-02-21 12:09:53 EST

*** This bug has been marked as a duplicate of 176726 ***

Note You need to log in before you can comment on or make changes to this bug.