Bug 176729 - starting >1 gnome-terminal locks up.
starting >1 gnome-terminal locks up.
Status: CLOSED DUPLICATE of bug 176029
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 21:43 EST by Dave Jones
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 15:51:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2005-12-30 21:43:23 EST
this is just... freaky.

if I start one gnome-terminal from the system menu, it starts up fine.
I can then run gnome-terminal from that first terminal, and a 2nd one pops up
fine. (I can start however many terminals I want this way).

If I try to start two terminals from the system menu though (or an icon I
dropped onto the menubar), the first one locks up, and the second terminal never
starts up.

This first started happening around the time that the gcc4.1 rebuild happened,
and something magical 'fixed' it shortly afterwards, even though there were no
updates that could be responsible for it.

It's now back again, and is driving me nuts, yarrr.

stracing the stuck gnome-terminal app shows its stuck waiting on a futex.
Given it only happens when started from the panel, I've filed this here rather
than against gnome-terminal.
Comment 1 Thomas M Steenholdt 2006-01-02 05:57:33 EST
This is definately not a panel bug. Problem occurs when launching gnome-terminal
from anywhere, but only when specifying some parameters. Like the default
launchers "--working-directory=<path>" or even just "--title=hhh" and such. This
could of course still be in some component that gnome-terminal utilizes, but for
now, please move bug to gnome-terminal, so it can get fixed.
Comment 2 Thomas M Steenholdt 2006-01-02 07:30:56 EST
--disable-factory helps - This is the backtrace and memory map captured from the
first gonme-terminal session, when starting number 2.


*** glibc detected *** gnome-terminal: malloc(): memory corruption: 0x09753df8 ***
======= Backtrace: =========
/lib/libc.so.6[0xc34ea0]
/lib/libc.so.6(calloc+0x8e)[0xc361e2]
/usr/lib/libglib-2.0.so.0(g_malloc0+0x38)[0x41b447f]
gnome-terminal[0x805deef]
/usr/lib/libbonobo-2.so.0(bonobo_marshal_VOID__STRING_BOXED_BOXED+0x5e)[0x78362b]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x11c)[0x2f6c9a]
/usr/lib/libbonobo-2.so.0(bonobo_closure_invoke_va_list+0x24d)[0x7826f9]
/usr/lib/libbonobo-2.so.0(bonobo_closure_invoke+0x180)[0x7828ea]
/usr/lib/libbonobo-2.so.0[0x7710ce]
/usr/lib/libbonobo-2.so.0(_ORBIT_skel_small_Bonobo_Listener_event+0x28)[0x78447d]
/usr/lib/libORBit-2.so.0[0x6599bb]
/usr/lib/libORBit-2.so.0(ORBit_OAObject_invoke+0x35)[0x65f56b]
/usr/lib/libORBit-2.so.0(ORBit_small_invoke_adaptor+0x464)[0x64d98b]
/usr/lib/libORBit-2.so.0[0x65d389]
/usr/lib/libORBit-2.so.0[0x65d9f0]
/usr/lib/libORBit-2.so.0[0x65e4c0]
/usr/lib/libORBit-2.so.0(ORBit_handle_request+0x97)[0x65f6e1]
/usr/lib/libORBit-2.so.0(giop_connection_handle_input+0x2c8)[0x649daa]
/usr/lib/libORBit-2.so.0[0x665abd]
/usr/lib/libORBit-2.so.0[0x668671]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x16e)[0x41ad943]
/usr/lib/libglib-2.0.so.0[0x41b0893]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a7)[0x41b0c3c]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0x3d0bd3c]
gnome-terminal[0x805e6e7]
/lib/libc.so.6(__libc_start_main+0xdc)[0xbe65b4]
gnome-terminal[0x8054011]
======= Memory map: ========
00101000-00108000 r-xp 00000000 fd:00 15370980   /usr/lib/libXrender.so.1.3.0
00108000-00109000 rwxp 00007000 fd:00 15370980   /usr/lib/libXrender.so.1.3.0
0010b000-0010f000 r-xp 00000000 fd:00 15371347   /usr/lib/libXfixes.so.3.0.0
0010f000-00110000 rwxp 00003000 fd:00 15371347   /usr/lib/libXfixes.so.3.0.0
00111000-00170000 r-xp 00000000 fd:00 15374750   /usr/lib/libbonoboui-2.so.0.0.0
00170000-00173000 rwxp 0005f000 fd:00 15374750   /usr/lib/libbonoboui-2.so.0.0.0
00173000-001f4000 r-xp 00000000 fd:00 15372022   /usr/lib/libgdk-x11-2.0.so.0.800.9
001f4000-001f7000 rwxp 00081000 fd:00 15372022   /usr/lib/libgdk-x11-2.0.so.0.800.9
001f7000-001fd000 r-xp 00000000 fd:00 15371065  
/usr/lib/libpangocairo-1.0.so.0.1101.0
001fd000-001fe000 rwxp 00006000 fd:00 15371065  
/usr/lib/libpangocairo-1.0.so.0.1101.0
001fe000-00206000 r-xp 00000000 fd:00 15374782  
/usr/lib/libstartup-notification-1.so.0.0.0
00206000-00207000 rwxp 00007000 fd:00 15374782  
/usr/lib/libstartup-notification-1.so.0.0.0
00207000-00209000 r-xp 00000000 fd:00 15371100   /usr/lib/libXinerama.so.1.0.0
00209000-0020a000 rwxp 00001000 fd:00 15371100   /usr/lib/libXinerama.so.1.0.0
0020a000-00211000 r-xp 00000000 fd:00 15371112   /usr/lib/libXi.so.6.0.0
00211000-00212000 rwxp 00006000 fd:00 15371112   /usr/lib/libXi.so.6.0.0
00212000-00215000 r-xp 00000000 fd:00 15371311   /usr/lib/libXrandr.so.2.0.0
00215000-00216000 rwxp 00002000 fd:00 15371311   /usr/lib/libXrandr.so.2.0.0
00216000-0021c000 r-xp 00000000 fd:00 15373274  
/usr/lib/libpangoxft-1.0.so.0.1101.0
0021c000-0021d000 rwxp 00006000 fd:00 15373274  
/usr/lib/libpangoxft-1.0.so.0.1101.0
0021f000-00254000 r-xp 00000000 fd:00 15374277   /usr/lib/libfontconfig.so.1.0.4
00254000-00258000 rwxp 00034000 fd:00 15374277   /usr/lib/libfontconfig.so.1.0.4
00258000-00259000 rwxp 00258000 00:00 0 
00259000-00262000 r-xp 00000000 fd:00 15371755   /usr/lib/libXcursor.so.1.0.2
00262000-00263000 rwxp 00008000 fd:00 15371755   /usr/lib/libXcursor.so.1.0.2
00265000-0026d000 r-xp 00000000 fd:00 15380122   /usr/lib/libSM.so.6.0.0
0026d000-0026e000 rwxp 00007000 fd:00 15380122   /usr/lib/libSM.so.6.0.0
0026e000-00278000 r-xp 00000000 fd:00 15375389   /usr/lib/libpangox-1.0.so.0.1101.0
00278000-00279000 rwxp 0000a000 fd:00 15375389   /usr/lib/libpangox-1.0.so.0.1101.0
00279000-0027b000 r-xp 00000000 fd:00 950497     /lib/libcom_err.so.2.1
0027b000-0027c000 rwxp 00001000 fd:00 950497     /lib/libcom_err.so.2.1
0027c000-00292000 r-xp 00000000 fd:00 15371141   /usr/lib/libICE.so.6.3.0
00292000-00294000 rwxp 0001500
Comment 3 Thomas M Steenholdt 2006-01-03 14:01:33 EST
The real problem may be with bonobo or something, but could someone please move
this to gnome-terminal, or another component if you have a good reason for doing
so? This is not a panel problem and the bug is probably not going to get much
attention before it hits the right shelf.
Thanks!
Comment 4 Christopher Aillon 2006-01-05 15:51:10 EST

*** This bug has been marked as a duplicate of 176029 ***

Note You need to log in before you can comment on or make changes to this bug.