Bug 176029 - Cannot start more than one gnome-terminal
Cannot start more than one gnome-terminal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 176039 176642 176729 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-17 16:02 EST by Clyde E. Kunkel
Modified: 2007-11-30 17:11 EST (History)
14 users (show)

See Also:
Fixed In Version: 2.13.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 15:54:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb log of gnome-terminal (9.16 KB, text/plain)
2005-12-18 05:53 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Clyde E. Kunkel 2005-12-17 16:02:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
When trying to start a second gnome terminal during a gnome desktop session, the second terminal never comes up and the first terminal freezes and has to be forced to exit.

Version-Release number of selected component (if applicable):
gnome-terminal-2.13.0-1

How reproducible:
Always

Steps to Reproduce:
1. start the first gnome-terminal by clicking on the menu entry
2. start the second gnome-terminal by clicking on the menu entry
3.
  

Actual Results:  The second terminal never starts, and the first terminal is frozen.

Expected Results:  Second terminal should start and be usable and the first terminal should also be usable.  Should be able to start several terminals.

Additional info:

Deleting the --working-directory=%f parameter in the invocation fixes the problem.

Not sure where this began, noticed on a fresh net install of rawhide of 16 Dec, and on another rawhide upgraded FC5T1 install.  It is not happening on another rawhide install that I have kept going since FC2 days.
Comment 1 Mamoru TASAKA 2005-12-18 05:53:37 EST
Created attachment 122375 [details]
gdb log of gnome-terminal

My problem on gnome-terminal is similar to this bug, so I attach
my gdb log for this bug.

The attached gdb log was created by the following steps:
1. First launch the other terminal (such as uxterm).
2. In uxterm, execute "gdb gnome-terminal" and run gdb
   ( then one gnome-terminal is launched).
3. In the launched gnome-terminal, execute 
    "gnome-terminal --working-directory=~"

Results: both gnome-terminal sessons freezes, and in uxterm terminal
glibc claiming messages about free() appears.

It seems that gnome-terminal cannot deal with the option
"--working-directory=???", as Clyde reported.
Comment 2 Mamoru TASAKA 2005-12-19 01:51:51 EST
Not only the option "--with-working-directory=foo" but many other
options such as "--show(hide)-menu-bars" "--zoom=??" and so on are also
broken (if used in second or later gnome-terminal).

By the way,  Joseph Sacco reported this bug to upstream as
http://bugzilla.gnome.org/show_bug.cgi?id=324443 .
Comment 3 Benjmain Youngdahl 2005-12-19 09:36:58 EST
*** Bug 176039 has been marked as a duplicate of this bug. ***
Comment 4 Mamoru TASAKA 2005-12-28 10:12:24 EST
The upstream bug noted in the comment 2 was marked as a duplicate of
http://bugzilla.gnome.org/show_bug.cgi?id=98715,
and in the gnome bug above (98715),  it is commented that Ilya Konstantinov
posted the REVERSE patch to RedHat bugzilla
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176642
to fix this problem temporarily.
Comment 5 Mike Chambers 2005-12-31 10:06:15 EST
This problem still exists on a rawhide install as of this morning.
Comment 6 John Ellson 2006-01-05 14:21:58 EST
Has fix gone in somewhere?

I can't reproduce the problem today, but I'm still running gnome-terminal-2.13.0-1
Comment 7 John Ellson 2006-01-05 15:10:32 EST
Forget #6   Its still there.  I think I confused things by upgrading glibc.
Comment 8 Christopher Aillon 2006-01-05 15:51:34 EST
*** Bug 176729 has been marked as a duplicate of this bug. ***
Comment 9 Christopher Aillon 2006-01-05 15:53:20 EST
*** Bug 176642 has been marked as a duplicate of this bug. ***
Comment 10 Christopher Aillon 2006-01-05 15:54:19 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.