Bug 17675 - ipchains init script should detect the kernel version
Summary: ipchains init script should detect the kernel version
Status: CLOSED DUPLICATE of bug 22612
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ipchains (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-19 07:58 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-08 21:45:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel 2.4 compatibility for ipchains script (318 bytes, patch)
2000-10-10 07:52 UTC, Pekka Savola
no flags Details | Diff

Description Pekka Savola 2000-09-19 07:58:26 UTC
RH 7.0 Final.

If you're using /etc/rc.d/init.d/ipchains, and upgrade to 2.4 kernel (e.g.
the preview one), the script
will start to complain loudly about the availability of proper firewalling
in the kernel.

If there is an easy way, the script should
 - Detect if 2.4 kernel is being used
 - (or, if easy) detect if proper firewalliing has been configured in

Comment 1 Nalin Dahyabhai 2000-09-19 16:39:58 UTC
Newer versions of the script check to make sure that you've at least got 2.2
installed.  Since the firewalling capabilities in 2.4 are implemented using
iptables, we'll have to figure out how to best deal with the transition.

Comment 2 Pekka Savola 2000-09-19 17:09:09 UTC
Well, it's not exactly graceful, but running 'ipchains -L -n' should always 
work without most of the side-effects (prints out ipchains: Incompatible 
with this kernel, for example).


Comment 3 Pekka Savola 2000-10-10 07:51:04 UTC
I thought about this a little.  iptables-save and -restore are broken right now,
and they're not
exactly very clean for transitioning.

The easiest way is to enable ipchains.o module which emulates ipchains if
init.d/ipchains is started.

A patch attached.

Comment 4 Pekka Savola 2000-10-10 07:52:18 UTC
Created attachment 3966 [details]
kernel 2.4 compatibility for ipchains script

Comment 5 Pekka Savola 2001-01-08 21:44:22 UTC
iptables-{save,restore} should work in iptables-1.2.0.


Comment 6 Pekka Savola 2001-01-08 21:57:03 UTC
gt@esi.ac.at's fix is better.

But notice that there's still save/restore issue to deal with, with regular iptables.

*** This bug has been marked as a duplicate of 22612 ***


Note You need to log in before you can comment on or make changes to this bug.