Bug 176759 - X crashes machine on VT switch back to X
X crashes machine on VT switch back to X
Status: CLOSED DUPLICATE of bug 187083
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2006-01-01 14:08 EST by Jesse Barnes
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-25 12:54:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jesse Barnes 2006-01-01 14:08:57 EST
Recent powerpc kernels (most recently 2.6.14-1.1806_FC5) don't come with the   
radeonfb driver, and I think this causes problems when X tries to exit.  
Previous configurations using the "UseFBDev" option set to "true" seemed to  
work ok, but since upgrading to modular, the X server causes a machine crash  
on exit or a vt switch back to X.  This might just be an X ati driver problem  
though, the device is an RV350 [Mobility Radeon 9600 M10] and I'm using the 
'radeon' driver (I'll try the 'ati' wrapper driver next to see if that changes 
Comment 1 Jesse Barnes 2006-01-19 15:04:28 EST
Nope, I see the same behavior even if I use the 'ati' wrapper driver.  And 
this is with the latest X packages from yesterday's rawhide update. 
I'll try to mess around a little more tonight and see if it's a dri problem or 
Comment 2 Jesse Barnes 2006-01-19 15:37:46 EST
Upping the severity as this bug causes a crash and generally makes the system 
Comment 3 Jesse Barnes 2006-01-21 13:49:59 EST
Disabling DRI (commening out the Load "dri" part of my xorg.conf) makes things 
work ok again, so I guess the problem isn't fb related after all. 
Comment 4 Jesse Barnes 2006-01-21 13:52:58 EST
Oops, spoke too soon.  It looks like X startup and exit is working ok, but VT 
switch is still broken.  Switching from the X VT to another VT and back still 
causes a crash. 
Comment 5 Jesse Barnes 2006-01-21 13:54:04 EST
Updating summary. 
Comment 6 Jesse Barnes 2006-01-21 14:37:41 EST
Ah, FB_RADEON support is builtin to this kernel, I was wondering how the 
console worked.  Unfortunately, setting "UseFBDev" to "true" still doesn't 
make the problem go away.  Start X, switch back to a console VT, switch back 
to X and boom, the machine is tottally wedged.  No panic, oops, or anything, 
just rainbow colors or a totally frozen display. 
Comment 7 Mike A. Harris 2006-01-31 19:58:09 EST
Please report this problem to X.org bugzilla at http://bugs.freedesktop.org
in the "xorg" component.  Be sure to attach your X server log file, and
config to the X.Org bug report and provide as much detail as you can to
ensure upstream PPC developers have as much information as possible in
order to diagnose the problem.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 8 Hans de Goede 2006-02-12 08:33:31 EST
I'm seeing something similar with the new xorg-x11-drv-ati- rpms, I've
tried both release -1 and release -4, unfortunatly I do not have an older
version to try. This is a fully up2date rawhide with a radeon 9250 (rv250) on
x86_64, this used to work fine with the older Modular driver and server version.

Whenever I try to switch back from console to X X-freezes, the rest of the
machine still works, I haven't tried remotely killing X, but it did complete a
yum update while X was hanging.

Killing X from the console and then restarting it also works fine, only when it
tries to restore its previous state it hangs.

Let me know if you want me to take this upstream, or if you want this in a
seperate bugreport.

Comment 9 Hans de Goede 2006-02-12 09:04:30 EST
Notice that the reporter of bug 178897 is experiencing the same problem with a
similar config, so now he can no longer do the required tests to advance bug 178897.

This all in all makes for 3 seperate people in bugzilla, all with radeon 92xx on
either powerpc or x86_64 with the following problem: startx, switch to VT,
switch back to X -> hang. Since the radeon 92xx is supposed to be the best card
when one wants free (as in speech) drivers, this is an awefull shame. I would
like to nominate this bug as an FC5 showstopper bug. Even though I know this
will happen I still accidently trigger this bug atleast once a day, which is
very anoying.

I've been doing some experimenting with packages from my yum cache and this does
not seem to be a xorg-x11-drv-ati problem, but rather a xorg-x11-server-Xorg
problem, downgrading to 1.0.0-3 or 0.99.3-9 fixes this, since 1.0.0-3 has broken
openGL support for radeon 92xx on x86_64 I'm back to 0.99.3-9, which it seems
was a rather good release (for me).
Comment 10 Mike A. Harris 2006-02-21 05:41:25 EST
For anyone still having this problem, please review comment #7 above and
update the bug report accordingly with an upstream bug URL.  Once the URL
is present, we will track the problem in X.Org bugzilla.

Thanks in advance.
Comment 11 Hans de Goede 2006-02-21 10:58:08 EST
I'm happy to report that this is fixed on x86_64 with the latest xorg rawhide
packages (and 3D still works).
Comment 12 Mike A. Harris 2006-02-21 11:08:47 EST
Jesse:  Can you confirm comment #11 on your system?

Comment 13 Jesse Barnes 2006-02-21 23:08:10 EST
I'll try to confirm tomorrow or Thu. when I have time (sorry I haven't filed 
the upstream bug, I've been tracking the problem via mail and irc w/benh 
trying to get it fixed). 
Comment 14 Jesse Barnes 2006-02-24 21:44:32 EST
Just upgraded to the latest today, and everything works again (though now I'm 
tracking a bug in freetype--kdm spins on ps_hints_apply for a long time when 
it starts up). 
Guess this one can be closed out! 
Comment 15 Jesse Barnes 2006-04-02 13:43:47 EDT
Looks like a DUP of 187083. 

*** This bug has been marked as a duplicate of 187083 ***

Note You need to log in before you can comment on or make changes to this bug.