Bug 178897 - Display glitch with Radeon 9200 : Vertical bar on the left at startup
Display glitch with Radeon 9200 : Vertical bar on the left at startup
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 05:45 EST by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 14:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (42.62 KB, text/plain)
2006-01-31 06:52 EST, Matthias Saou
no flags Details
Xorg config file (2.63 KB, text/plain)
2006-01-31 06:53 EST, Matthias Saou
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 9891 None None None Never

  None (edit)
Description Matthias Saou 2006-01-25 05:45:57 EST
I just installed Rawhide on an x86_64 Shuttle barebone, with an ATI Radeon 9200
video card, connected through the DVI port to a TV, configured to do 1280x1024
(60Hz it seems).

The rhgb screen looks fine, at 1280x1024. But once the main GNOME desktop
appears (I have set gdm auto login), the last few pixels of the right of the
screen appear on the left... think of the screen moved a couple of dozen pixels
to the right, but wrapping around. It's quite strange and somewhat annoying.

The "fix" I've found is to simply Ctrl+Alt+F1 to tty1 and Ctrl+Alt+F7 back to X,
where things are then fine again.
Comment 1 Mike A. Harris 2006-01-27 18:31:55 EST
Very odd.  Sounds like an off by one error somewhere in the driver.

Please attach your X server log file and config file from the problematic
scenario, as individual uncompressed file attachments, using the link
below.

TIA
Comment 2 Matthias Saou 2006-01-31 06:52:52 EST
Created attachment 123906 [details]
Xorg log file
Comment 3 Matthias Saou 2006-01-31 06:53:40 EST
Created attachment 123907 [details]
Xorg config file
Comment 4 Mike A. Harris 2006-01-31 18:38:42 EST
Would it be possible to get you to try a test-install the i386 release to
see if it can be reproduced there as well?  I'm curious if it affects only
x86_64, or if it is also seen on i386, etc.

Definitely sounds like a driver bug though.  
Comment 5 Matthias Saou 2006-02-01 04:40:21 EST
Well, I guess I can try and do that... I'll try ASAP and let you know.
Would it be interesting to try the VGA out too, in order to see if it affects
only the DVI output?
Comment 6 Mike A. Harris 2006-02-01 06:00:08 EST
Yeah, if that's not too much trouble, that would be useful info.

Thanks.
Comment 7 Matthias Saou 2006-02-02 05:58:42 EST
So :
- Simply switching to the VGA out instead of the DVI with the computer powered
  off, then turning it on, gets me all the way into GNOME properly and the
  glitch isn't present.
- When using DVI, the glitch is also present on the rhgb screen. This was
  probably unclear in my first comment ("looks fine"), and isn't seen easily
  since the background is mostly solid color, but it can definitely be seen.

I haven't been able to try an i386 reinstall yet, but will do. For now it seems
that it's at least DVI specific, and can easily go away by going to any tty and
re-entering X.
Comment 8 Matthias Saou 2006-02-03 04:15:28 EST
I tried upgrading to today's Rawhide, and now when switching to a tty and back
into X, the entire display freezes, and keyboard input too sometimes. When the
keyboard still works, Ctrl+Atl+Suppr works, and in all cases the power button of
the computer still performs a clean shutdown.

This is definitely a different bug, and unfortunately the vertical bar is still
present.
Comment 9 Hans de Goede 2006-02-12 08:36:20 EST
Glad to hear you're not the only one having the X freezes when switching back to
X from a console problem. I have it too, also with a radeon 92xx on x86_64, see
bug 176759.
Comment 10 Mike A. Harris 2006-02-21 06:22:25 EST
Does this problem still occur with FC5test3?
Comment 11 Matthias Saou 2006-02-21 06:33:50 EST
The freeze when going from the console back to X is gone now, but the vertical
bar glitch is still there after a complete Rawhide update yesterday. Still
haven't been able to test an i386 install on that machine, though :-(

Hans : Are you using DVI on your Radeon 92xx?
Comment 12 Mike A. Harris 2006-03-06 17:57:17 EST
Can someone attach a screen shot or digital picture of the problem?  Unable
to reproduce locally.
Comment 13 Matthias Saou 2006-03-08 05:26:16 EST
Here's my most overkill bug report attachment so far :
http://ftp.es6.freshrpms.net/tmp/bug178897.avi (12M XviD movie)

The problem is also present during rhgb (although it's too hard to see it on
the video), and you can see in the video that Crtl+Alt+F1 immediately followed
by Alt+F7 gets back to X with the problem gone).

Now I also need to dig to find out why I couldn't make a Theora file with
mencoder nor with transcode ;-)
Comment 14 Matthias Saou 2006-03-15 05:09:14 EST
I've got a new piece of (relevant) information. And I'm getting each time more
confused...

When I boot up the computer with the TV turned off, or with the TV's input set
to something else than DVI, the vertical bar isn't there! (when I later switch
to DVI to check once booting is finished)

When I boot up the computer with the display on the TV, the vertical bar is
always there (rhgb + X) like seen on the video linked above.

I've diff'ed the two X logs, and the only difference is (IIRC) on the PLL
line where a huge value is slightly different. I'll attach that diff as soon
as I can.
Comment 15 Mike A. Harris 2006-06-27 13:42:05 EDT
(In reply to comment #14)
> I've diff'ed the two X logs, and the only difference is (IIRC) on the PLL
> line where a huge value is slightly different. I'll attach that diff as soon
> as I can.

How soon might that be...  ;)  No pressure, just curious...  ;o)
Comment 16 Matthias Saou 2006-06-27 13:54:00 EDT
Oh, sorry, I completely forgot. But there were no significant differences
between both log files at all. Only the line that cocntains the current "Time",
and the max= value of the "PLL parameters", but that also changed between two
consecutive startups with the same connections.

This still happens with FC5 + updates. I suppose you'd now be interested in
knowing if it still does with Rawhide?
Comment 17 Matthias Saou 2006-06-28 12:50:50 EDT
FYI, this still happens after updating the system to today's Rawhide. One
interesting thing though is that I now have "hibernate" in the GNOME power
applet and that after resuming from swsusp, even with the TV on, the display is
fine, unlike when doing a full boot.
Comment 18 Matthias Saou 2006-10-02 15:34:00 EDT
Current rawhide still exhibits the problem. Note that trying the "vesa" driver
instead of the "radeon" one fixes it, so it seems specific to the "radeon".
Comment 19 Matthias Saou 2007-02-06 08:53:46 EST
I'm still seeing this problem with the current development tree. I've filed the
bug upstream against XOrg here :
https://bugs.freedesktop.org/show_bug.cgi?id=9891
Comment 20 Matthias Saou 2007-03-05 10:25:33 EST
FWIW, I also see this exact same problem during Fedora 7t2's graphical
installation, as well as during RHEL5's. Also once the system is installed. So
on my hardware it's 100% reproducible without any special settings.

Is there anything I could try to provide more useful feedback?
Comment 21 Adam Jackson 2007-05-03 14:49:01 EDT
Tracking this upstream.

Note You need to log in before you can comment on or make changes to this bug.