Bug 176761 - snd-powermac not loaded auotmatically anymore
snd-powermac not loaded auotmatically anymore
Status: CLOSED DUPLICATE of bug 178466
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 185195 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-01 14:11 EST by Jesse Barnes
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 11:17:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsound.log (4.66 KB, text/x-log)
2006-02-20 14:32 EST, Pete Graner
no flags Details

  None (edit)
Description Jesse Barnes 2006-01-01 14:11:56 EST
Not sure when this started occurring, but after a recent upgrade my powerbook 
stopped loading 'snd-powermac' at boot time, causing later scripts that depend 
on the mixer to fail.
Comment 1 W. Michael Petullo 2006-01-03 15:16:45 EST
I also see this problem.  I am using an iBook.  After the system boots I have to
manually modprobe snd-pcm-oss and snd-pcm-mixer.  This was not necessary before.
 However, like Jesse, I do not know at what point this problem surfaced.

I am tracking Raw Hide.
Comment 2 Jesse Barnes 2006-02-03 21:50:06 EST
Just FYI, this still occurs using the 2.6.15-1.1898_FC5 kernel.  
Comment 3 shrek-m 2006-02-14 12:45:23 EST
still no sound after system boot - powermac g5
2.6.15-1.1948_FC5
udev-084-1.ppc64
udev-084-1.1.ppc

# esd
ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_card_driver
returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_concat returned
error: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_refer returned
error: No such device
ALSA lib conf.c:3961:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default

# modprobe snd_powermac
# esd
"duedeldidei"
Comment 4 Pete Graner 2006-02-20 14:31:19 EST
Having the same exact problem here on my powerbook. Attaching scsound.log
Comment 5 Pete Graner 2006-02-20 14:32:44 EST
Created attachment 124899 [details]
scsound.log
Comment 6 Eugene Savelov 2006-03-11 12:08:37 EST
*** Bug 185195 has been marked as a duplicate of this bug. ***
Comment 7 Eugene Savelov 2006-03-11 12:12:14 EST
probably sound modules should be loaded in 
/etc/sysconfig/modules/udev-stw.modules? currently, it loads only

#!/bin/sh
for i in nvram floppy parport_pc parport lp;do
        modprobe $i >/dev/null 2>&1
done
Comment 8 Bill Nottingham 2006-03-24 11:17:25 EST

*** This bug has been marked as a duplicate of 178466 ***

Note You need to log in before you can comment on or make changes to this bug.