Bug 185195 - Fedora kernel sound modules do not get loaded on PowerPC mac mini
Fedora kernel sound modules do not get loaded on PowerPC mac mini
Status: CLOSED DUPLICATE of bug 176761
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-11 11:34 EST by Eugene Savelov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-11 12:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eugene Savelov 2006-03-11 11:34:33 EST
Description of problem:

sound is configured, modprobe.conf - 
alias snd-card-0 snd-powermac
options snd-card-0 index=0
options snd-powermac index=0
remove snd-powermac { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-powermac

however, on bootup sound modules do not get loaded,  but as a wrokaround,
inserting USB audi headset gets the modules loaded, and integrated sound starts
working 

[root@localhost modprobe.d]# /sbin/lsmod
Module                  Size  Used by
snd_usb_audio          90688  0
snd_powermac           53836  1
snd_seq_dummy           4004  0
snd_seq_oss            42580  0
snd_seq_midi_event      8576  1 snd_seq_oss
snd_seq                67136  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            65296  0
snd_mixer_oss          22560  2 snd_pcm_oss
snd_pcm               105380  3 snd_usb_audio,snd_powermac,snd_pcm_oss
snd_timer              30404  2 snd_seq,snd_pcm
snd_page_alloc         12392  1 snd_pcm
snd_usb_lib            19488  1 snd_usb_audio
snd_rawmidi            32032  1 snd_usb_lib
snd_seq_device         11148  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_hwdep              12100  1 snd_usb_audio
snd                    72724  11
snd_usb_audio,snd_powermac,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_rawmidi,snd_seq_device,snd_hwdep
soundcore              11652  2 snd

[
Version-Release number of selected component (if applicable):
module-init-tools-3.2-0.pre9.2.2.1
kernel-2.6.15-1.2041_FC5
alsa-utils-1.0.11-3.rc2


How reproducible:

Always

Steps to Reproduce:
1) install fedora core5test3 on mac mini powerpc
2) check sound - doesn;t work
3) insert usb headset 
4) run soundcard detection - it works

  
Actual results:

sound works only after inserting USB headset

Expected results:

integrated sound should work. (works in fedora core4)

Additional info:
Comment 1 Eugene Savelov 2006-03-11 12:03:02 EST
version of udev - udev-084-1.1

/etc/sysconfig/modules/udev-stw.modules

#!/bin/sh
for i in nvram floppy parport_pc parport lp;do
        modprobe $i >/dev/null 2>&1
done
Comment 2 Eugene Savelov 2006-03-11 12:08:15 EST

*** This bug has been marked as a duplicate of 176761 ***

Note You need to log in before you can comment on or make changes to this bug.