Bug 1767629 - Metering - openshift-metering/hive-metastore-0 - Exception in thread "main" MetaException(message:java.lang.ClassNotFoundException: Class com.google.cloud.hadoop.fs.gcs.GoogleHadoopFileSystem not found)
Summary: Metering - openshift-metering/hive-metastore-0 - Exception in thread "main" M...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metering Operator
Version: 4.2.z
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Brett Tofel
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On:
Blocks: 1767634
TreeView+ depends on / blocked
 
Reported: 2019-10-31 20:38 UTC by Mattia Mascia
Modified: 2020-01-23 11:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The Hadoop Dockerfile.rhel copied the gcs-connector jar to the wrong location in the container. Now, the path has been corrected to point to the right location.
Clone Of:
: 1767634 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:10:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
hive metastore container log (53.94 KB, application/octet-stream)
2019-10-31 20:38 UTC, Mattia Mascia
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework hadoop pull 21 0 'None' closed bug 1767629: Dockerfile.rhel: Fix location of gcs-connector jar 2020-06-05 12:02:10 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:10:30 UTC

Description Mattia Mascia 2019-10-31 20:38:24 UTC
Created attachment 1631228 [details]
hive metastore container log

Description of problem:

Currently, the hive metastore application goes in an exception at startup.

This is happening only on the openshift4/ose-metering-hive:4.2 image (metastore container). the upstream image openshift/origin-metering-hive:4.2 is working fine.

In attach the full logs.

I guess is a matter to propagate the fix in downstream.

The workaround is to override the hive repository:

apiVersion: metering.openshift.io/v1
kind: MeteringConfig
metadata:
  name: operator-metering
  namespace: openshift-metering
spec:
  hive:
    spec:
      image:
        repository: quay.io/openshift/origin-metering-hive
        tag: '4.2'
  storage:
    hive:
      gcs:
        bucket: pro-reports
        region: europe-west3
        secretName: gcs-secret
      type: gcs
    type: hive


Version-Release number of selected component (if applicable): 4.2


How reproducible: Deploy OpenShift Metering


Steps to Reproduce:
1. Install Red Hat OpenShift Metering Operator with Operator Hub
2. Create a simple MeteringConfig
3. Check start up log of metastore container in the hive-metastore statefulset.

Actual results:
- CrashLoopBackoff

Expected results:
- Start correctly

Additional info:

Comment 2 Peter Ruan 2019-11-06 18:03:48 UTC
verified with     image: quay.io/openshift/origin-metering-hive:4.2

Comment 5 errata-xmlrpc 2020-01-23 11:10:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.