Bug 1767634 - Metering - openshift-metering/hive-metastore-0 - Exception in thread "main" MetaException(message:java.lang.ClassNotFoundException: Class com.google.cloud.hadoop.fs.gcs.GoogleHadoopFileSystem not found)
Summary: Metering - openshift-metering/hive-metastore-0 - Exception in thread "main" M...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metering Operator
Version: 4.2.z
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Brett Tofel
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On: 1767629
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-31 20:56 UTC by Chance Zibolski
Modified: 2020-01-22 10:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1767629
Environment:
Last Closed: 2020-01-22 10:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework hadoop pull 22 None None None 2020-01-07 18:59:30 UTC
Red Hat Product Errata RHBA-2020:0107 None None None 2020-01-22 10:47:03 UTC

Description Chance Zibolski 2019-10-31 20:56:40 UTC
+++ This bug was initially created as a clone of Bug #1767629 +++

Description of problem:

Currently, the hive metastore application goes in an exception at startup.

This is happening only on the openshift4/ose-metering-hive:4.2 image (metastore container). the upstream image openshift/origin-metering-hive:4.2 is working fine.

In attach the full logs.

I guess is a matter to propagate the fix in downstream.

The workaround is to override the hive repository:

apiVersion: metering.openshift.io/v1
kind: MeteringConfig
metadata:
  name: operator-metering
  namespace: openshift-metering
spec:
  hive:
    spec:
      image:
        repository: quay.io/openshift/origin-metering-hive
        tag: '4.2'
  storage:
    hive:
      gcs:
        bucket: pro-reports
        region: europe-west3
        secretName: gcs-secret
      type: gcs
    type: hive


Version-Release number of selected component (if applicable): 4.2


How reproducible: Deploy OpenShift Metering


Steps to Reproduce:
1. Install Red Hat OpenShift Metering Operator with Operator Hub
2. Create a simple MeteringConfig
3. Check start up log of metastore container in the hive-metastore statefulset.

Actual results:
- CrashLoopBackoff

Expected results:
- Start correctly

Additional info:

Comment 3 Peter Ruan 2020-01-15 01:01:22 UTC
verified with the example meteringconfig after installing via OLM
       
    startedAt: "2020-01-15T00:14:12Z"
  - containerID: cri-o://571f6d0df3aed032524558361b7dde250f9eb0d4f7847f566d847139f1692f52
    image: image-registry.openshift-image-registry.svc:5000/openshift/ose-metering-hive@sha256:5fade3d075177f7f1ddc44a9626c5b9fa95ec958918c50715b5cd5b22d522145
    imageID: image-registry.openshift-image-registry.svc:5000/openshift/ose-metering-hive@sha256:5fade3d075177f7f1ddc44a9626c5b9fa95ec958918c50715b5cd5b22d522145

Comment 5 errata-xmlrpc 2020-01-22 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0107


Note You need to log in before you can comment on or make changes to this bug.