Bug 176774 - dbus starts too late
dbus starts too late
Status: CLOSED DUPLICATE of bug 176522
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-02 03:28 EST by Reuben Farrelly
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-14 05:17:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2006-01-02 03:28:13 EST
Description of problem:

There is an issue with /etc/init.d/bluetooth, specifically the 'hcid' daemon
being started on boot.
I have a Logitech MX900 mouse which uses bluetooth connectivity, however it no
longer comes up when the machine is started.  I need to go in and run:

/etc/init.d/bluetooth restart

for it to work.

Note that when I do the restart, Bluetooth is listed as "Failed" when shutting
down, but starts up succesfully.  If I manually invoke hcid from the command
line it works OK and my mouse starts working and any subsequent restart of
bluetooth services returns OK to the stop and start.

This has worked fine until some time in December when it suddenly stopped
working, however I am not sure of the exact date that it broke.

Version-Release number of selected component (if applicable):
Current Rawhide as of 02 Jan, bluez-utils-2.22-2.1

How reproducible:
Every time.

Steps to Reproduce:
1. Boot the machine
2. Note that bluetooth services "Fail" to start
3. Further note that the sdpd daemon is running but not hcid
  
Actual results:
* Bluetooth mouse doesn't work.
Comment 1 Reuben Farrelly 2006-01-14 04:39:13 EST
I think I've figured out why.

I noticed this logged earlier hidden in /var/log/messages:

Jan 14 22:28:56 typhoon hcid[2351]: Can't open system message bus connection:
Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or
directory
Jan 14 22:28:56 typhoon sdpd[2356]: Bluetooth SDP daemon
Jan 14 22:28:56 typhoon hcid[2351]: Unable to get on D-BUS

Also noted that the messagebus service which is part of the dbus infrastructure
does not start till S97, whereas bluetooth starts at S25.  So I guess that hcid
tries to start first but fails due to dbus being non operational at the time.

If this is the cause can it be please sorted before FC5 final?  Otherwise anyone
with bluetooth and that depends on hcid is basically going to find it just won't
work.
Comment 2 David Woodhouse 2006-01-14 04:52:20 EST
I think there's already a bug open for this.
Comment 3 Reuben Farrelly 2006-01-14 05:17:19 EST
Yep there is, it's the same bug for sure.

Now if only it could be made a blocker for FC5 or at least the priority bumped
up..........


*** This bug has been marked as a duplicate of 176522 ***

Note You need to log in before you can comment on or make changes to this bug.