Bug 1768341 - The cursor always moves to the end if try to add Aggregation operators to one typed metrics
Summary: The cursor always moves to the end if try to add Aggregation operators to one...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.3.0
Assignee: Andrew Pickering
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1773121 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-04 06:47 UTC by Junqi Zhao
Modified: 2020-01-23 11:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:10:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
The cursor always moves to the end (63.77 KB, image/png)
2019-11-04 06:47 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3253 'None' closed Bug 1768341: Query Browser: Fix bug where the cursor jumped to the end of the input 2020-02-20 10:42:27 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:10:40 UTC

Description Junqi Zhao 2019-11-04 06:47:57 UTC
Created attachment 1632415 [details]
The cursor always moves to the end

Description of problem:
Query Browser, type one metrics first, example: machine_cpu_cores, I want to add sum() Aggregation operator to the metrics, the full expression would be sum(machine_cpu_cores), after typing the first letter "s" of sum(), the cursor moves to the end, it is now smachine_cpu_cores. see the picture

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-02-092336

How reproducible:
Always

Steps to Reproduce:
1. See the description
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Junqi Zhao 2019-11-12 00:38:54 UTC
Issue is fixed with 4.3.0-0.nightly-2019-11-11-182924

Comment 4 Andrew Pickering 2019-11-18 08:40:52 UTC
*** Bug 1773121 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2020-01-23 11:10:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.