Bug 1773121 - Metrics query lister unusuable on Chrome / Mac when trying to type at beginning of typeahead field and metric present
Summary: Metrics query lister unusuable on Chrome / Mac when trying to type at beginni...
Keywords:
Status: CLOSED DUPLICATE of bug 1768341
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Andrew Pickering
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-15 23:05 UTC by Clayton Coleman
Modified: 2019-11-18 08:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-18 08:40:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Clayton Coleman 2019-11-15 23:05:06 UTC
1. Go to Metrics tab
2. Paste a metric from the dropdown (haproxy_backend_connections_total)
3. Put focus on query input at end
4. Hit home key, try to type

Actual:

Tried to type "irate(" at the beginning of the metric, the first character went to the first position in line (so "ihaproxy_backend_connections_total") and then cursor position went to end of line so I ended up typing "ihaproxy_backend_connections_totalrate("

Unable to actually move around and enter metrics queries on Chrome/Mac, thus high.

Comment 1 Andrew Pickering 2019-11-18 08:40:52 UTC
Same as https://bugzilla.redhat.com/show_bug.cgi?id=1768341

Fix was merged 2019-11-11

*** This bug has been marked as a duplicate of bug 1768341 ***


Note You need to log in before you can comment on or make changes to this bug.