Bug 176850 - geomview-plugins needs to be rebuilt for geomview-1.8.2-0.1.cvs20040221.fc4
geomview-plugins needs to be rebuilt for geomview-1.8.2-0.1.cvs20040221.fc4
Product: Fedora
Classification: Fedora
Component: geomview (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: 177000 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-01-03 14:13 EST by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.8.2-0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-04 11:32:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-01-03 14:13:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Galeon/2.0.0

Description of problem:
geomview-plugins has not been rebuilt for new geomview, blocking updates.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. rpm -q geomview geomview-plugins
2. sudo yum upgrade


Actual Results:  Before upgrade 
$ rpm -q geomview geomview-plugins

During upgrade

$ sudo yum upgrade
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Excluding Packages from JPackage 1.6, generic
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.


--> Running transaction check
--> Processing Dependency: geomview = 1.8.1 for package: geomview-plugins
--> Processing Dependency: tomcat5-servlet-2.4-api = 0:5.0.30-8jpp for package: tomcat5
--> Finished Dependency Resolution
Error: Missing Dependency: geomview = 1.8.1 is needed by package geomview-plugins

Expected Results:  geomview package (including geomview-plugins) should have been upgraded.

Additional info:
Comment 1 Rex Dieter 2006-01-03 14:25:16 EST
NOTABUG (shouldn't be anyway), since there is no geomview-plugins subpkg anymore.

New package includes:
Obsoletes: geomview-plugins
Provides:  geomview-plugins

Comment 2 Rex Dieter 2006-01-03 14:26:57 EST
Looks like the Obsoletes/Provides were missed somehow... reopening.
Comment 3 Alex Lancaster 2006-01-03 14:29:59 EST
Doesn't look the obsoletes got added:

$ rpm -q --provides --obsoletes geomview
geomview = 1.8.2-0.1.cvs20040221.fc4

If they had got added properly then "yum upgrade" wouldn't have complained and
the plugins package would have been obsoleted correctly and the upgrade should
have proceeded, and the plugins subpackage would have been removed.
Comment 4 Rex Dieter 2006-01-04 11:32:45 EST
geomview = 1.8.2-0.2 and later should now include the proper Obsoletes/Provides
Comment 5 Rex Dieter 2006-01-05 07:58:19 EST
*** Bug 177000 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.