Bug 1769615 - The metrics of "service_catalog_apiserver_enabled" is missing
Summary: The metrics of "service_catalog_apiserver_enabled" is missing
Keywords:
Status: CLOSED DUPLICATE of bug 1769602
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: Jesus M. Rodriguez
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-07 02:05 UTC by Jesus M. Rodriguez
Modified: 2019-11-11 06:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1769601
Environment:
Last Closed: 2019-11-11 06:08:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-svcat-apiserver-operator pull 69 None None None 2019-11-07 02:09:27 UTC

Description Jesus M. Rodriguez 2019-11-07 02:05:04 UTC
This bug also affects the service_catalog_apiserver_enabled metric.

+++ This bug was initially created as a clone of Bug #1769601 +++

Description of problem:
No "service_catalog_controller_manager_enabled
" from the metrics data of catalog controller manager.

Version-Release number of selected component (if applicable):
cv: 4.3.0-0.nightly-2019-11-05-211939

How reproducible:
always

Steps to Reproduce:
1.oc -n openshift-monitoring exec -c prometheus prometheus-k8s-1  -- curl -k -H "Authorization: Bearer $token" https://10.129.0.22:8443/metrics (get this url from the prometheus' targets) | grep service_catalog_controller_manager_enabled


Actual results:
1. no metrics "service_catalog_controller_manager_enabled"

Expected results:
1. should be "service_catalog_controller_manager_enabled 0"
and after enable the servicecatalogcontrollermanager the metrics will become "service_catalog_controller_manager_enabled 1"


Additional info:

Comment 2 Fan Jia 2019-11-08 07:53:58 UTC
No nightly build include this fix PR for now

Comment 3 Fan Jia 2019-11-11 03:32:02 UTC
test env:
cv:4.3.0-0.nightly-2019-11-10-165138

test result:
The metrics "service_catalog_apiserver_enabled" exist and equal "0" at first. After enable the servicecatalogapiserver the metrics will become "service_catalog_apiserver_enabled 1" , and the Alert "ServiceCatalogAPIServerEnabled" becomes "Firing".

Comment 4 Fan Jia 2019-11-11 06:08:34 UTC

*** This bug has been marked as a duplicate of bug 1769602 ***


Note You need to log in before you can comment on or make changes to this bug.