Bug 1769601 - The metrics of "service_catalog_controller_manager_enabled" is missing
Summary: The metrics of "service_catalog_controller_manager_enabled" is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: Jesus M. Rodriguez
QA Contact: Fan Jia
URL:
Whiteboard:
: 1744739 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-06 23:18 UTC by Fan Jia
Modified: 2020-01-23 11:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1769615 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:11:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-svcat-controller-manager-operator pull 59 'None' closed Bug 1769601: Register with the legacyregistry for metrics 2020-04-01 15:05:20 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:11:31 UTC

Description Fan Jia 2019-11-06 23:18:49 UTC
Description of problem:
No "service_catalog_controller_manager_enabled
" from the metrics data of catalog controller manager.

Version-Release number of selected component (if applicable):
cv: 4.3.0-0.nightly-2019-11-05-211939

How reproducible:
always

Steps to Reproduce:
1.oc -n openshift-monitoring exec -c prometheus prometheus-k8s-1  -- curl -k -H "Authorization: Bearer $token" https://10.129.0.22:8443/metrics (get this url from the prometheus' targets) | grep service_catalog_controller_manager_enabled


Actual results:
1. no metrics "service_catalog_controller_manager_enabled"

Expected results:
1. should be "service_catalog_controller_manager_enabled 0"
and after enable the servicecatalogcontrollermanager the metrics will become "service_catalog_controller_manager_enabled 1"


Additional info:

Comment 2 Fan Jia 2019-11-08 07:53:35 UTC
No nightly build include this fix PR

Comment 3 Fan Jia 2019-11-11 03:30:57 UTC
test env:
cv:4.3.0-0.nightly-2019-11-10-165138

test result:
The metrics "service_catalog_controller_manager_enabled" exist and equal "0" at first. After enable the servicecatalogcontrollermanager the metrics will become "service_catalog_controller_manager_enabled 1" , and the Alert "ServiceCatalogControllerManagerEnabled" becomes "Firing"

Comment 4 Jesus M. Rodriguez 2019-11-20 18:07:03 UTC
*** Bug 1744739 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2020-01-23 11:11:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.