Bug 1769717 - MachineAPIOperatorDown alert is threw out after upgrade OCP from 4.2 to 4.3
Summary: MachineAPIOperatorDown alert is threw out after upgrade OCP from 4.2 to 4.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Abhinav Dahiya
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1776297
TreeView+ depends on / blocked
 
Reported: 2019-11-07 09:51 UTC by Junqi Zhao
Modified: 2020-05-13 21:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1776297 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:52:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-version-operator pull 272 'None' closed Bug 1769717: Add support to EnsureServicePorts 2020-11-12 10:51:16 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:52:25 UTC

Comment 3 Alberto 2019-11-14 08:34:42 UTC
Junqi Zhao I can't reproduce this. Please reopen if still relevant.

Comment 7 Alberto 2019-11-25 11:35:50 UTC
The CVO synced the mao service
I1125 09:03:02.498470       1 sync_worker.go:634] Done syncing for service "openshift-machine-api/machine-api-operator" (106 of 492)

How ever it still have the old ports

apiVersion: v1
kind: Service
metadata:
  annotations:
    exclude.release.openshift.io/internal-openshift-hosted: "true"
    service.alpha.openshift.io/serving-cert-secret-name: machine-api-operator-tls
    service.alpha.openshift.io/serving-cert-signed-by: openshift-service-serving-signer@1574643525
    service.beta.openshift.io/serving-cert-signed-by: openshift-service-serving-signer@1574643525
  creationTimestamp: "2019-11-25T00:57:06Z"
  labels:
    k8s-app: machine-api-operator
  name: machine-api-operator
  namespace: openshift-machine-api
  resourceVersion: "99725"
  selfLink: /api/v1/namespaces/openshift-machine-api/services/machine-api-operator
  uid: 808fab3a-0f1e-11ea-b0d6-0226aba6a282
spec:
  clusterIP: 172.30.86.189
  ports:
  - name: metrics
    port: 8080
    protocol: TCP
    targetPort: metrics
  selector:
    k8s-app: machine-api-operator
  sessionAffinity: None
  type: ClusterIP
status:
  loadBalancer: {}

Comment 8 Scott Dodson 2019-12-02 15:06:39 UTC
*** Bug 1776725 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2020-05-13 21:52:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.