Bug 176999 - MEMORY test fails due to bug in test script
Summary: MEMORY test fails due to bug in test script
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: memory
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Will Woods
QA Contact: Rob Landry
URL:
Whiteboard:
Keywords:
: 179136 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-05 05:12 UTC by Rainer Koenig
Modified: 2018-10-19 20:46 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-05-08 13:37:37 UTC


Attachments (Terms of Use)
Fixed MEMORY test for rhr2-2.0 (2.29 KB, text/plain)
2006-01-12 21:10 UTC, Will Woods
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0278 normal SHIPPED_LIVE rhr2 bug fix update 2006-05-08 04:00:00 UTC
Red Hat Product Errata RHBA-2006:0284 normal SHIPPED_LIVE rhr2 bug fix update 2006-05-08 04:00:00 UTC

Description Rainer Koenig 2006-01-05 05:12:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)

Description of problem:
Installed rhr2-2.0 on a test machine and did the MEMORY test. Result was that the test failed. 



Version-Release number of selected component (if applicable):
rhr2-2.0

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4
2. Install rhr2-2.0 test suite
3. Run MEMORY test
  

Actual Results:  Test interface reported error after the test.

Expected Results:  No error.

Additional info:

I had a look at the output.log of the MEMORY test. It dies here:
Line# 59:  echo "Starting RHTS memtest"
Line# 60:  cp $EXTERNALS/bin/{memtst,memtest.sh} .

The problem is that the cp in line 60 fails because memtest.sh is not under $EXTERNALS/bin/
Doing a rpm -ql rhr2-2.0 | grep memt shows:
/usr/share/rhr/external/bin/memtst
/usr/share/rhr/external/memtest.sh

A workaround for this is create a hard link in /usr/share/rhr/external/bin for memtest.sh.

Comment 1 Will Woods 2006-01-12 20:54:18 UTC
I've confirmed this problem and committed a fix to CVS; this bug will be fixed
in the next version of rhr2.

That workaround is acceptable, but I strongly recommend running MEMORY2 instead.

Comment 2 Will Woods 2006-01-12 21:10:09 UTC
Created attachment 123138 [details]
Fixed MEMORY test for rhr2-2.0

Comment 3 Will Woods 2006-01-12 21:12:19 UTC
Could you please try the above MEMORY test to confirm that it solves the
problem? Just copy it to /usr/share/rhr/tests/MEMORY and run a MEMORY test.


Comment 4 Will Woods 2006-01-31 18:16:32 UTC
*** Bug 179136 has been marked as a duplicate of this bug. ***

Comment 5 natarajan 2006-03-13 06:42:05 UTC
(In reply to comment #4)
> *** Bug 179136 has been marked as a duplicate of this bug. ***

Hi,
sorry for intefernce,
i faced same problem what desribed above and i used fixed memory script for 
running memory test. now its working fine. thanx for all who given me solution.

Comment 8 Red Hat Bugzilla 2006-05-08 13:37:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0278.html


Comment 9 Red Hat Bugzilla 2006-05-08 13:37:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0284.html



Note You need to log in before you can comment on or make changes to this bug.