Bug 177032 - Kernel panic when connecting USB device
Kernel panic when connecting USB device
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-01-05 11:01 EST by Göran Uddeborg
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.15-1.1830_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-06 12:09:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output from dmesg (22.01 KB, text/plain)
2006-01-06 05:33 EST, Göran Uddeborg
no flags Details

  None (edit)
Description Göran Uddeborg 2006-01-05 11:01:49 EST
Description of problem:
The machine is new, I'm setting it up.  Whenever I plug in a USB device, the
kernel crashes.  I've tried both a Lacie DVD writer and an Olympus digital
camera, and get the same result.

When I installed the system, I made an installation DVD and tried to install
from the DVD.  I was able to boot from it, but it couldn't find it to boot from.
 I never investigated that further, but did an FTP install instead.

If I plug the USB unit in before booting the machine, it stops with the first
line from the kernel panic stack below.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1.Plug in a USB unit

Actual results:
Kernel panic

Expected results:
The device should show up.

Additional info:
Processor: AMD Athlon 64 X2 4400+
Motherboard: Asus A8N-E
Memory: 4 GB
lspci output:
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]
05:08.0 Ethernet controller: VIA Technologies, Inc. VT86C100A [Rhine] (rev 06)

Kernel stack trace:  (beware that this is written down from screen to paper, and
then from paper to a file, so there could be misspellings)

lKernel panic - not syncing: PCI-DMA: high address but no IOMMU

Call Trace:<ffffffff80134831>{panic+133} <ffffffff8012d816>{complete+57}
 <ffffffff80130a60>{try_to_wake_up+1028} <ffffffff801fbab4>{kobject_get+18}
 <ffffffff8101d535>{dma_map_simple+176} <ffffffff802ad9bd>{hcd_submit_urb+1670}
 <ffffffff8012d75a>{__wake_up+56} <ffffffff801358c0>{vprintk+887}
 <ffffffff803431b8>{_spin_lock_irqsave+9} <ffffffff802ae74b>{usb_start_wait_urb+114}
 <ffffffff80135958>{printk+78} <ffffffff802ae98d>{usb_control_msg+234}
 <ffffffff802aa67d>{hub_port_init+588} <ffffffff802ab633>{hub_trhead+1483}
 <ffffffff80149f20>{autoremove_wake_function+0} <ffffffff802ab068>{hub_thread+0}
 <ffffffff80149ad0>{keventd_create_kthread+0} <ffffffff80149d27>{kthread+203}
 <ffffffff80130f21>{schedule_tail+70} <ffffffff8010ea16>{child_rip+8}
 <ffffffff80149ad0>{keventd_create_kthread+0} <ffffffff80149c5c>{kthread+0}
Comment 1 Pete Zaitcev 2006-01-06 00:27:37 EST
Please attach a full dmesg (do not drop into the comments box).
I suspect that swiotlb saw 4GB and decided not to initialize,
but some memory hole or other made a part of memory to move above 4GB.
Comment 2 Göran Uddeborg 2006-01-06 05:33:08 EST
Created attachment 122863 [details]
Output from dmesg

There are two settings in the BIOS concerning DRAM remappings: "S/W DRAM Over
4G Remapping" and a line which is identical except that it starts with "H/W". 
They are not mentioned in the printed manual.  Both were enabled.  I tried to
disable both.  That gave me only 3 GB when running, but USB units started to
Comment 3 Pete Zaitcev 2006-01-06 14:21:44 EST
I see this in dmesg:

BIOS-e820: 0000000100000000 - 0000000140000000 (usable)
Checking aperture...
CPU 0: aperture @ 8000000 size 32 MB
Aperture from northbridge cpu 0 too small (32 MB)
No AGP bridge found
Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
Mapping aperture over 65536 KB of RAM @ 8000000

So, this is an AMD CPU, so swiotlb is not applicable (and it has normal
iommu mode). The iommu is enabled, with difficulties, but for some reason
it did not work...

We need someone who is an Opteron specialist here.
Comment 4 Göran Uddeborg 2006-01-06 15:50:55 EST
Strictly speaking it's not an Opteron but an Athlon 64 X2.  (Maybe that is the
same thing as far as these things are concerned.  I don't know.  With this
comment I just want to prevent any possible mistakes.)
Comment 5 Göran Uddeborg 2006-01-22 12:35:27 EST
Another aspect of what I guess is the same underlying bug:  When I tried to
activate the separate network card (05:08.0 in the lcpci listing in comment 0),
I again get a crash with the message

   Kernel panic - not syncing: PCI-DMA: high address but no IOMMU

No stack trace this time.  I have had the card in the machine for some time
without problems.  But when I tried to activate it (ONBOOT=yes), then the kernel
crashes during startup.

As before, if I disable the two BIOS settings things work, but I only get 3 GB
of available memory.
Comment 6 Dave Jones 2006-02-03 01:59:25 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 7 Göran Uddeborg 2006-02-06 12:09:25 EST
The problem seems to be fixed in this release.  I could use both the USB camera
and the network card, without crashing the machine.

Note You need to log in before you can comment on or make changes to this bug.