Bug 1770378 - [DR] etcd-generate-certs.yaml.template is not in line with etcd-member.yaml
Summary: [DR] etcd-generate-certs.yaml.template is not in line with etcd-member.yaml
Keywords:
Status: CLOSED DUPLICATE of bug 1773562
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1773562
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-08 20:06 UTC by Sam Batschelet
Modified: 2019-11-23 01:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1773562 (view as bug list)
Environment:
Last Closed: 2019-11-23 01:29:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1255 0 'None' 'closed' 'Bug 1773562: templates/master/00-master: update recovery template to work with setup-etcd-environment' 2019-11-23 01:16:03 UTC

Description Sam Batschelet 2019-11-08 20:06:14 UTC
Description of problem: machine-config-operator/templates/master/00-master/_base/files/usr-local-share-openshift-recovery-template-etcd-generate-certs-yaml-template.yaml contains a spec used for recovery. This spec has drifted from the actual etcd-member.yaml static spec deployed by MCO.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: DR template matches MCO config.


Additional info:

Comment 1 Sam Batschelet 2019-11-08 20:30:51 UTC
The main issue here is `setup-etcd-environment` had some changes for 4.3 and these changes were not reflected in the DR template.

Comment 3 Sam Batschelet 2019-11-23 01:29:32 UTC
This fix is actually already in 4.4 and 4.3 closing as a dupe.

*** This bug has been marked as a duplicate of bug 1773562 ***


Note You need to log in before you can comment on or make changes to this bug.