Bug 1773562 - [DR] etcd-generate-certs.yaml.template is not in line with etcd-member.yaml
Summary: [DR] etcd-generate-certs.yaml.template is not in line with etcd-member.yaml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
: 1770378 (view as bug list)
Depends On:
Blocks: 1770378
TreeView+ depends on / blocked
 
Reported: 2019-11-18 13:13 UTC by Antonio Murdaca
Modified: 2020-05-04 11:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1770378
Environment:
Last Closed: 2020-05-04 11:15:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:16:14 UTC

Description Antonio Murdaca 2019-11-18 13:13:13 UTC
+++ This bug was initially created as a clone of Bug #1770378 +++

Description of problem: machine-config-operator/templates/master/00-master/_base/files/usr-local-share-openshift-recovery-template-etcd-generate-certs-yaml-template.yaml contains a spec used for recovery. This spec has drifted from the actual etcd-member.yaml static spec deployed by MCO.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: DR template matches MCO config.


Additional info:

--- Additional comment from Sam Batschelet on 2019-11-08 20:30:51 UTC ---

The main issue here is `setup-etcd-environment` had some changes for 4.3 and these changes were not reflected in the DR template.

Comment 2 Sam Batschelet 2019-11-23 01:29:32 UTC
*** Bug 1770378 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-05-04 11:15:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.