Bug 1770997 - The (best) screenshot tool "shutter" is currently broken in Fedora 31
Summary: The (best) screenshot tool "shutter" is currently broken in Fedora 31
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shutter
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Liang Suilong
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-11 16:32 UTC by Basic Six
Modified: 2019-12-11 02:06 UTC (History)
4 users (show)

Fixed In Version: shutter-0.94.3-1.fc31
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-11 02:06:11 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Basic Six 2019-11-11 16:32:59 UTC
Description of problem:

The screenshot tool "shutter" - probably the best, most flexible and useful screenshot and editing tool out there - is currently broken in Fedora 31.

It won't start because a Perl library has changed:

$ shutter 
"glob" is not exported by the File::Glob module
Can't continue after import errors at /usr/bin/shutter line 57.
BEGIN failed--compilation aborted at /usr/bin/shutter line 57.



Version-Release number of selected component (if applicable):

shutter-0.93.1-14.fc31.noarch
perl-5.30.0-446.fc31.x86_64



Additional info:

Comment 1 Rafael Reuber 2019-11-15 23:19:37 UTC
+1

Comment 2 Bobses 2019-11-16 07:47:44 UTC
Confirm the bug.

Comment 3 Bobses 2019-11-16 07:49:43 UTC
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1749499

Comment 4 Fedora Update System 2019-12-09 14:28:00 UTC
FEDORA-2019-973addd47d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-973addd47d

Comment 5 Fedora Update System 2019-12-10 18:47:15 UTC
shutter-0.94.3-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-973addd47d

Comment 6 Fedora Update System 2019-12-11 02:06:11 UTC
shutter-0.94.3-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.