Bug 177224 - Ooo has crashed! on FC4 PPC Titanium series
Ooo has crashed! on FC4 PPC Titanium series
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 177441 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-07 17:41 EST by Leopoldo Olmos
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 03:10:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Document (1.01 MB, application/msword)
2006-01-20 12:58 EST, Leopoldo Olmos
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 59924 None None None Never

  None (edit)
Description Leopoldo Olmos 2006-01-07 17:41:23 EST
Description of problem: 
Ooo has crashed! on FC4 PPC Titanium every time on every component of the suite


Version-Release number of selected component (if applicable):
OpenOffice.org core rpm version is openoffice.org-core-2.0.1.1-4.1


How reproducible:
Allways

Steps to Reproduce:
1.Open any Ooo aplication
2.
3.
  
Actual results:
Video Driver is probably radeon
DESKTOP_SESSION is set to default
libgcj version is libgcj-4.0.2-8.fc4
OpenOffice.org core rpm version is openoffice.org-core-2.0.1.1-4.1
0xf417b98: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x27b98
0xf418440: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x28440
0x7f967798: ????????
0x105360a0: ????????
0x25c9adc: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0xc39adc
(SdrPageViewWindow::Redraw(Region const&, unsigned short, unsigned char const*,
sdr::contact::ViewObjectContactRedirector*) const + 0x31c)
0x25ce3e0: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0xc3e3e0
(SdrPageView::DrawLayer(unsigned char, Rectangle const&, OutputDevice*, unsigned
short) const + 0x80)
0x326ed48: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x22ed48
0x33e8224: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x3a8224
0x32731bc: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x2331bc
(ViewShell::Paint(Rectangle const&) + 0x578)
0x3240c34: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x200c34
(SwCrsrShell::Paint(Rectangle const&) + 0x64)
0x3932394: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x8f2394
0xef479ac: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x2779ac
0xef4768c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x27768c
0xef4768c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x27768c
0xef4768c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x27768c
0xef4768c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x27768c
0xef4768c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x27768c
0xef4768c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x27768c
0xef48b34: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x278b34
0xed65814: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95814
(Timer::Timeout() + 0x34)
0xed65e4c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95e4c
0xe7512ec: /usr/lib/openoffice.org2.0/program/libvclplug_gen680lp.so + 0x522ec
(SalData::Timeout() const + 0x48)
0xe7bcb60: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680lp.so + 0x21b60
0x30820284: /usr/lib/libglib-2.0.so.0 + 0x33284
0x3081da94: /usr/lib/libglib-2.0.so.0 + 0x30a94 (g_main_context_dispatch + 0x280)
0x30821d6c: /usr/lib/libglib-2.0.so.0 + 0x34d6c
0x30822458: /usr/lib/libglib-2.0.so.0 + 0x35458 (g_main_context_iteration + 0x84)
0xe7bc984: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680lp.so + 0x21984
0xe759a74: /usr/lib/openoffice.org2.0/program/libvclplug_gen680lp.so + 0x5aa74
(X11SalInstance::Yield(unsigned char) + 0x40)
0xed5d75c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x8d75c
(Application::Yield() + 0x78)
0xed5d834: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x8d834
(Application::Execute() + 0x70)
0x2e77dac: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x27dac
(desktop::Desktop::Main() + 0x1028)
0xed65200: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95200
0xed652c4: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x952c4 (SVMain()
+ 0x34)
0x2e6dd80: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd80 (sal_main
+ 0x5c)
0x2e6de10: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1de10 (main + 0x30)
0xfe8b7cc: /lib/libc.so.6 + 0x1b7cc
0xfe8b964: /lib/libc.so.6 + 0x1b964 (__libc_start_main + 0xb4)

Expected results:
Open an Ooo doc

Additional info: System fully updated
Comment 1 Caolan McNamara 2006-01-12 06:06:29 EST
I wonder if https://bugs.freedesktop.org/show_bug.cgi?id=5125 is relevent here
Comment 2 Caolan McNamara 2006-01-18 05:28:10 EST
how about with 2.0.1.1-5.1 for fc4 updates ?
Comment 3 Leopoldo Olmos 2006-01-19 21:33:58 EST
(In reply to comment #2)
> how about with 2.0.1.1-5.1 for fc4 updates ?

The problem solved inmediately after the 2.0.1.1-5.1 update, just to come again
following the latest yum updates:

Video Driver is probably radeon
DESKTOP_SESSION is set to kde
libgcj version is libgcj-4.0.2-8.fc4
OpenOffice.org core rpm version is openoffice.org-core-2.0.1.1-5.1
0xf517b98: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x27b98
0xf518440: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x28440
0x7fa8b9c8: ????????
0x1ff5844: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0x355844
0x1ff6804: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0x356804
0x1ff8158: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0x358158
0x1ff85d4: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0x3585d4
0x3494940: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x474940
0x33a6ed8: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x386ed8
0x33a727c: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x38727c
0x33a7b24: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x387b24
0x3252548: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x232548
(ViewShell::LayoutIdle() + 0xd4)
0x34d1628: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x4b1628
0xd5814: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95814
(Timer::Timeout() + 0x34)
0xd5e4c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95e4c
0xe7512ec: /usr/lib/openoffice.org2.0/program/libvclplug_gen680lp.so + 0x522ec
(SalData::Timeout() const + 0x48)
0xe7bcb60: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680lp.so + 0x21b60
0x30820284: /usr/lib/libglib-2.0.so.0 + 0x33284
0x3081da94: /usr/lib/libglib-2.0.so.0 + 0x30a94 (g_main_context_dispatch + 0x280)
0x30821d6c: /usr/lib/libglib-2.0.so.0 + 0x34d6c
0x30822458: /usr/lib/libglib-2.0.so.0 + 0x35458 (g_main_context_iteration + 0x84)
0xe7bc984: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680lp.so + 0x21984
0xe759a74: /usr/lib/openoffice.org2.0/program/libvclplug_gen680lp.so + 0x5aa74
(X11SalInstance::Yield(unsigned char) + 0x40)
0xcd75c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x8d75c
(Application::Yield() + 0x78)
0xcd844: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x8d844
(Application::Execute() + 0x80)
0x1c57dac: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x27dac
(desktop::Desktop::Main() + 0x1028)
0xd5200: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95200
0xd52c4: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x952c4 (SVMain() +
0x34)
0x1c4dd80: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd80 (sal_main
+ 0x5c)
0x1c4de10: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1de10 (main + 0x30)
0xfe8b7cc: /lib/libc.so.6 + 0x1b7cc
0xfe8b964: /lib/libc.so.6 + 0x1b964 (__libc_start_main + 0xb4)
Comment 4 Caolan McNamara 2006-01-20 03:59:02 EST
does it do the same thing under gnome ?
Comment 5 Leopoldo Olmos 2006-01-20 06:01:45 EST
Yes, but it worked fine on both -gnome and kde- just before updating
libwpd-0.8.4-0, foomatic -3.0.2-19.2, libcap-0.8.3-14, tcpdump-3.8.2-14,
autofs-4.1.4-15 and hal-0.5.2-2
Comment 6 Caolan McNamara 2006-01-20 07:19:25 EST
*** Bug 177441 has been marked as a duplicate of this bug. ***
Comment 7 Leopoldo Olmos 2006-01-20 12:58:22 EST
Created attachment 123495 [details]
Document
Comment 8 Leopoldo Olmos 2006-01-20 13:03:37 EST
(In reply to comment #7)
> Created an attachment (id=123495) [edit]
> Document
> I have just attached a problematic file, but actually I can not open any file
with the open office suit.
Comment 9 Caolan McNamara 2006-02-13 03:10:06 EST
http://www.openoffice.org/issues/show_bug.cgi?id=59924 reports that it was
kernel related and went away on a new kernel

Note You need to log in before you can comment on or make changes to this bug.