Bug 177441 - Opening .doc file from evolution causes OO to crash
Opening .doc file from evolution causes OO to crash
Status: CLOSED DUPLICATE of bug 177224
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 177442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 13:56 EST by Nigel Horne
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-20 07:19:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2006-01-10 13:56:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-GB; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Trying to open a word document from within Evolution caused a crash.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.1-143.2.1

How reproducible:
Sometimes

Steps to Reproduce:
1. click on the attachment
2 [details].
3.
  

Actual Results:  Video Driver is probably radeon
DESKTOP_SESSION is set to default
libgcj version is libgcj-4.0.2-8.fc4
OpenOffice.org core rpm version is openoffice.org-core-2.0.1-143.2.1
0xf687b98: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x27b98
0xf688440: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x28440
0x7fc2a4e8: ????????
0x1d85884: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0x355884
0x1d86844: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0x356844
0x1d88198: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0x358198
0x1d88614: /usr/lib/openoffice.org2.0/program/libsvx680lp.so + 0x358614
0x3554a80: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x474a80
0x3467018: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x387018
0x34673bc: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x3873bc
0x3467c64: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x387c64
0x3312548: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x232548 (ViewShell::LayoutIdle() + 0xd4)
0x3591768: /usr/lib/openoffice.org2.0/program/libsw680lp.so + 0x4b1768
0x425834: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95834 (Timer::Timeout() + 0x34)
0x425e6c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95e6c
0xe7812ec: /usr/lib/openoffice.org2.0/program/libvclplug_gen680lp.so + 0x522ec (SalData::Timeout() const + 0x48)
0xe7ecc50: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680lp.so + 0x21c50
0x30828284: /usr/lib/libglib-2.0.so.0 + 0x33284
0x30825a94: /usr/lib/libglib-2.0.so.0 + 0x30a94 (g_main_context_dispatch + 0x280)
0x30829d6c: /usr/lib/libglib-2.0.so.0 + 0x34d6c
0x3082a458: /usr/lib/libglib-2.0.so.0 + 0x35458 (g_main_context_iteration + 0x84)
0xe7eca74: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680lp.so + 0x21a74
0xe789a74: /usr/lib/openoffice.org2.0/program/libvclplug_gen680lp.so + 0x5aa74 (X11SalInstance::Yield(unsigned char) + 0x40)
0x41d77c: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x8d77c (Application::Yield() + 0x78)
0x41d854: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x8d854 (Application::Execute() + 0x70)
0x2b823c: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x2823c (desktop::Desktop::Main() + 0x1028)
0x425220: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x95220
0x4252e4: /usr/lib/openoffice.org2.0/program/libvcl680lp.so + 0x952e4 (SVMain() + 0x34)
0x2ae210: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1e210 (sal_main + 0x5c)
0x2ae2a0: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1e2a0 (main + 0x30)
0xfe8b7cc: /lib/libc.so.6 + 0x1b7cc
0xfe8b964: /lib/libc.so.6 + 0x1b964 (__libc_start_main + 0xb4)

Expected Results:  File should open

Additional info:
Comment 1 Caolan McNamara 2006-01-12 05:00:19 EST
*** Bug 177442 has been marked as a duplicate of this bug. ***
Comment 2 Caolan McNamara 2006-01-12 05:03:35 EST
I'd need to see the sample .doc document which causes this
Comment 3 Nigel Horne 2006-01-12 05:12:23 EST
The document is confidential, so that is out of the question. However I can
report that if I save the file to hard disc and open OO from there it works fine
so it is an interaction between Evolution and OO.
Comment 4 Caolan McNamara 2006-01-12 06:03:04 EST
Yeah, but sending myself a .doc is working for me (on ix86 anyway) :-(
Comment 5 Nigel Horne 2006-01-12 06:54:34 EST
It works ok for me on an x86 as well, which points to a PPC issue.
Comment 6 Caolan McNamara 2006-01-20 07:19:24 EST

*** This bug has been marked as a duplicate of 177224 ***

Note You need to log in before you can comment on or make changes to this bug.